I'm holding out for the ThinkPad Helix 2, which has a detachable tablet as a screen. It comes out later this month. I've heard that installing Linux on bleeding edge technology can be problematic due to driver issues, etc.

Would I likely be able to use this computer to its fullest with Ubuntu (or, better yet, some customized Arch Linux installation)? I'm fairly new to Linux in case that matters.

  • If you want "bleeding edge" you need a full source based distro, like Gentoo using ~ia64 as your arch, and corei7-avx in your CFLAGS
    – eyoung100
    Commented Oct 2, 2014 at 13:45
  • 3
    I've used Thinkpad/Lenovo products for years and I don't see why there reasonably good support of providing hardware that works with Linux would subside now. Also here's a thread for Helix 1 - forums.lenovo.com/t5/Linux-Discussion/Linux-on-ThinkPad-Helix/…
    – slm
    Commented Oct 2, 2014 at 14:41

4 Answers 4


I've recently installed ArchLinux + GNOME 3 on the ThinkPad Helix 2, and mostly everything works out of the box.

My biggest remaining issue is suspend; a bug report has been filed to fix it but they're still seeking more information. (So perhaps trying it yourself will help! ;)) The pen works wonderfully, palm rejection is perfect in Xournal. A few things need a little work to get working, namely:

  1. Sound and microphone support. Just run the following script which unmutes the speaker, headphones, and mic, and enables the appropriate devices:

    #speakers (SPO)
    amixer -c 1 cset numid=24 on
    amixer -c 1 cset numid=25 on
    #headphones (HPO)
    amixer -c 1 cset numid=26 on
    amixer -c 1 cset numid=27 on
    #microphone (ADC0 Capture Switch / ADC0 Capture Vol / ADC0 Mux / ADC 1 Mux / Mic Vol)
    amixer -c 1 cset numid=8 "on,on"
    amixer -c 1 cset numid=9 "127"
    amixer -c 1 cset numid=19 "2"
    amixer -c 1 cset numid=20 "2"
    amixer -c 1 cset numid=4 "30,30"

    You'll need to run alsactl store as root when the keyboard is not docked, for for reasons I can't discern this command has issues when the keyboard is connected, and will not run automatically.

  2. LTE support. For some reason, I suppose because the Sierra Wireless EM7345 card is still fairly recent, mbim (which the kernel defaults to) is not supported out of the box with Network Manager + ModemManager. I had to add a file with the following contents in my /etc/modprobe.d

    options cdc_ncm prefer_mbim=N

    And then NetworkManager picked up on my SIM card and connected just fine. (Using T-Mobile.) Otherwise, NetworkManager was connecting but only locally.

  3. Autorotate tablet into laptop mode and back when docked. This isn't so much of an issue as it is 'something nice to have', but I felt it deserved a mention. When the tablet is docked, an ACPI event is registered, and you can take advantage of that to autorotate the tablet. Using the script helix-rotate available via the AUR I made two scripts which I added to my /etc/acpi/actions directory (requires installing acpid from the community repo):


    export XAUTHORITY=/run/user/1000/gdm/Xauthority
    export DISPLAY=:0
    current_orientation="$(xrandr --query --verbose | awk 'NR==2 { if ($2 = /connected/) print $6}')"
    if [ "$current_orientation" = "right" ] && [ -z "$1" ]; then 
       helix-rotate left 
    elif [ "$current_orientation" = "inverted" ] && [ -z "$1" ]; then 
       helix-rotate flip
    elif [ "$current_orientation" = "left" ] && [ -z "$1" ]; then 
       helix-rotate right


    XAUTHORITY=/run/user/1000/gdm/Xauthority DISPLAY=:0 helix-rotate left

    Then in my handler.sh (this should be under case "$1"):

            case "$4" in
                            logger 'Tablet detached'
                            logger 'Tablet docked'

    You'll need to enable the acpid daemon with systemctl enable acpid.service (as root) for any of the above to work.

  4. Bluetooth. I had to reset the device before it worked, though you might not need to. The command to do so is hciconfig -a hci0 reset. You might also want to install pulseaudio-bluetooth for sound support.

There are a few other tweaks I probably did, but those are all the important ones I can recall. Some software I highly recommend are pstate-frequency-git, tlp, Easystroke, and the aforementioned Xournal.

I'm sorry this post is rather lengthy and better suited to an ArchWiki page, but I would like to flesh this out a bit before posting it to the ArchWiki, and at the same time wanted to provide you with something substantial enough that you could get started, without hopefully feeling too intimidated, preferably with ArchLinux. ;) Best of luck to you!

As an aside, one thing I find super neat is that the Quickshot Cover (a $50 accessory) works in Linux (closing the cover suspends the tablet), but alas due to the aforementioned suspend issue one cannot resume from suspend. :( So I have temporarily disabled suspend via the lid/cover in GNOME via the GNOME Tweak Tool, and it only dims the display while covered instead.

PS: I just realized that this was posted in 2014, not 2015, so though what I've posted is applicable to your model, there was no reason to rush. XD Nonetheless, I hope this information helps someone.

  • That script for turning on audio is good, but on my machine, the card number seems to move around. I retrieved it as card=$(arecord -l | grep -o '[0-9]: broadwellrt286' | uniq | grep -o '^[0-9]') and changed all -c 1 to -c $card. Commented Jan 4, 2016 at 16:25
  • More elegant too, thanks for the input! :) Commented Jan 4, 2016 at 16:28

Graphics Analysis

HD 4K Support in Kernel 3.10 and UP

  • Device contains Code-Name IVY BRIDGE Intel HD 4K Graphics Chip.
  • IVY Bridge should fall under the MESA DRI on LKDB.
  • Support Options: FOSS MESA DRI Driver or Official Intel i965 Driver.

Wireless Analysis

MBM Ericson Chipset Support

  • Unsure if this is within the LKDB, but packages exist here.

I have installed Debian testing Jessie on the Thinkpad Helix. Overall the experience is acceptable. The tablet works, the pen works, the docking system works. It runs very hot, but I'm reasonably sure would happen with any OS, and I haven't tried any tricks to tune it.

I'd recommend the effort.


I just got a ThinkPad Helix 2 with an "Ultrabook Pro" keyboard. With Ubuntu 14.04, the keyboard was not recognized. (The flimsy keyboard that comes with the machine by default is recognized.) This is fixed in Ubuntu 15.10.

I had difficulty getting the DP port driving my external monitor (2560x1600). I had to add a custom mode with frequency 30Hz. (NB. For some reason, the external DP port is shown as HDMI2.)

The above-mentioned sound fix works in Ubuntu as well.

Suspend has never worked for me, and hibernate works intermittently. See here and here. That's not quite the dealbreaker that I thought it would be because the battery life is pretty good.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .