1

I have cacti working flawlessly on a centos 7.0 machine but I need it working on a centos 6.3 machine. I download the same version of cacti as what is on the 7.0 and I installed rrdtool from yum. After performing a successful base installation of cacti and confirm it works. I then copy over the database rsync /var/mysql/mydb and restart mysqld I see my data but ‘none of the charts appear’ and I get this error in my cacti.log

10/01/2014 04:12:31 AM - CMDPHP: Poller[0] ERROR: SQL Row Failed!, Error:'1033', SQL:"select  host.id,  host.hostname,  host.snmp_community,  host.snmp_version,  host.snmp_username,  host.snmp_password,  host.snmp_auth_protocol,  host.snmp_priv_passphrase,  host.snmp_priv_protocol,  host.snmp_context,  host.snmp_port,  host.snmp_timeout,  host.disabled  from host  where host.id=1"

since, I have upgraded MySQL to 5.4 and rddtool to 1.4.8 and tried a different cacti versions also. I have also tried every script in cli/ to repair the DB or bring it up to specs. Mysqlcheck say the database is just fine. Same error

How do I get my cacti charts to work?

5
  • Error 1033 – eyoung100 Oct 2 '14 at 22:23
  • @eyoung100 my database engine is MyISAM paste.ee/p/vzWHt , I have already tried to delete both the ib_logfile* files and nothing 'tmp' exist in my.cnf, though permissions are correct for /tmp (system default) – brad Oct 2 '14 at 22:45
  • Well Googling Error 1033 only brings up InnoDB. I looked High and Low about 3 pages deep. – eyoung100 Oct 2 '14 at 22:49
  • @eyoung100 on a hunch I started to convert each table to InnoDB, one by one because scripting failed and I got a very interesting error -> bpaste.net/show/f4f793883498 ERROR 1033 (HY000): Incorrect information in file: './cacti3/host.frm' – brad Oct 2 '14 at 23:14
  • That past confirms all the errors I found on Google – eyoung100 Oct 2 '14 at 23:16
0

the tables plugin_flowview_schedules and host were corrupt and mysqlcheck was not detecting this. found while converting each table one by one to InnoDB and got the 1033 error. I did a mysql export of just the tables and then imported the .sql into the CentOS 6 machine and the error went away and the graphs popped right up. Note that I rsync'ed the /var/lib/mysql/* migration and probably should of done a traditional mysql export and would of saved myself the headaches.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.