0

So I've been trying out linux, and regardless of what I do, I end up getting no sound at all. I've tried researching the matter to no luck. At first I tried Debian, then moved onto Elementary OS, and now I'm at Kubuntu, figuring that Ubuntu had more of its software up-to-date, so it should be able to play sound on my system.

No such luck. Kubuntu clearly recognizes my built-in sound cards, but isn't outputting any kind of sound, whether I play from a browser or VLC.

If there's any other kind of information I have to provide, you may have to explain it to me, as I'm not familiar with the way Linux operates.

$ cat /proc/asound/cards
 0 [HDMI           ]: HDA-Intel - HDA ATI HDMI
                  HDA ATI HDMI at 0xfeb44000 irq 55
 1 [Generic        ]: HDA-Intel - HD-Audio Generic
                  HD-Audio Generic at 0xfeb40000 irq 16
2
  • With Kubuntu, you're using KDE? It's been my experience that if the hardware is detected correctly that the DE is the culprit in blocking audio output. Check w/ KDE's sound applet to see where it thinks it's directing the audio.
    – slm
    Oct 1 '14 at 23:50
  • A common pitfall is that sound systems typically have many volume controls, and it's not that rare to have one somehow set to mute. Beware that some volume applications will not show all volume controls, try several and try unmuting all the settings, even the ones that don't seem relevant at first sight. Oct 2 '14 at 20:41
0

Since you have two cards, you are almost certainly outputting to the wrong one. Exporting ALSA_CARD=Generic may help; if you're using pulse there's probably a better way but just restarting the daemon will probably work.

I have never found KDE's configuration dialog at all useful.

0

Your first audio sound card is HDMI audio : you must set your 2nd sound card as default .
Use sound system setting , "output" tab, select this "Generic" sound card.
If not working, you can install and run pavucontrol (Pulseaudio volume control), scroll down to access the 2nd sound card in the "output device" tab and click green button near it to make it default.

If not ok, run this commands in a terminal :
rm -r ~/.config/pulse; pulseaudio -k `

If stills bad, check alsa audio layer running alsamixer in a maximized terminal , press F6 , select 2nd soundcard , then use arrow keys:

  • left/right arrow keys to select faders
  • up/down keys to change level (increase all faders level)
  • "m" key to mute/unmute faders (if a fader is muted , you see "MM" under it. if not muted, "00")

If stills bad , run "Alsa-info" to post your audio config: copy the following command in a terminal , choose "upload" option when asked ("tab" key to select it) an post url printed at the end.
wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh && bash alsa-info.sh

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.