4

I have an embedded PC running Angstrom Linux. When the network is unavailable during the boot, it won't become available when I for example connect it to a network afterwards. When I reboot the device (which I'd like to avoid), it works because the network is available from the beginning.

I tried to bring the Eth0 interface up with ifup eth0, but it ended with error message: ifup: can't open '/etc/network/interfaces': No such file or directory. (Of course, the network is managed by Conman now and the classic folders from other Linux OS are not present. I wonder why they kept ifup present in the system...). So I tried to restart the interface with:

service network restart
/etc/init.d/network restart
/etc/init.d/networking restart

None of the commands worked. How do I restart the eth0 interface on the embedded PC running Angstrom OS → recognize Ethernet cable plugged in after boot?

3
  • Can you install ifplugd? – eyoung100 Oct 1 '14 at 14:01
  • @eyoung100: I tried. There's already busybox present in the OS, but it doesn't contain ifplugd. I'm currently trying to get a new version, but opkg refuses to download it. – 0x0000eWan Oct 1 '14 at 14:19
  • Well ifplugd is the detection daemon for the network cable, so you need this tool or it's equivalent for your distro. – eyoung100 Oct 1 '14 at 14:22
1

The issue in not recognizing when the Ethernet cable is reconnected was caused by a hardware error. I replaced the embedded PC and it worked fine.

But still, sometimes the network becomes unreachable even when other devices in the network can reach it without a problem and this can be fixed by running following command:

systemctl restart network.target

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.