167

When attempting to launch system-config-users from command line, I get the following warning, and the tool does not open. I'm using CentOS 7 with Mate 1.8.1.

WARNING **: Error enumerating actions: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.PolicyKit1 was not provided by any .service files

Error checking for authorization org.freedesktop.policykit.exec: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.PolicyKit1 was not provided by any .service files

yum list polkit*

Installed Packages
polkit.x86_64   0.112-5.el7 @anaconda
polkit-devel.x86_64 0.112-5.el7 @base    
polkit-docs.noarch 0.112-5.el7 @base    
polkit-gnome.x86_64 0.105-6.el7 @epel    
polkit-pkla-compat.x86_64 0.1-4.el7  @anaconda

What is missing from my system to cause this error?

12
  • Do you happen to be using XFCE?
    – eyoung100
    Sep 30, 2014 at 19:14
  • I'm using Mate 1.8.1
    – a coder
    Sep 30, 2014 at 19:21
  • Since I can't tell what services are being enumerated, I can't tell you which package to install. The error is not caused by policykit, but by one of the services policykit is attempting to load. XFCE has this issue with udisks
    – eyoung100
    Sep 30, 2014 at 19:24
  • Is there a way to monitor what services policykit is using or attempting to use?
    – a coder
    Sep 30, 2014 at 19:27
  • Not that I know of. Pre-systemd systems use policykit/consolekit in conjuction with Dbus to enforce login permissions. This leads to two possibilities. 1. The user you're logged in as is not a member of some group, and some group has permission to access the missing service. 2. One of the services monitored by system-config-users is not installed. As a hunch, search your package repo for mate-polkit
    – eyoung100
    Sep 30, 2014 at 19:41

3 Answers 3

271

I just had the same return when installing deluged on arch, I typed:

 systemctl start deluged

I tried with sudo and it worked fine. Seems to be a group permissions issue.

All I did was enable permissions for my user account and then typed:

 sudo systemctl start deluged

worked like a charm.

7
  • 14
    Really weird message, unlike *nix. Would never have thought this would be the solution! Thanks!
    – Sufian
    Aug 8, 2015 at 8:32
  • 11
    Ah right, of course sudo. It would be really helpful if they had a system in place which would return an error like "root privileges required" or something a little more obvious.
    – Mint
    Mar 8, 2016 at 7:51
  • 35
    Possibly the most counter-intuitive error ever.
    – ffledgling
    Feb 28, 2017 at 13:20
  • 2
    It's probably complaining that you don't have Polkit set up which you would need to allow non-user systemctl without root privileges. Just a guess though Jul 11, 2017 at 2:29
  • Worked for me too, thx Jul 18, 2019 at 14:38
138

To clarify and summarize SNP22's post: You probably just forgot sudo.:

sudo systemctl [...]

Absolutely misleading warning ...

2
  • 2
    Probably join the list of bad error message reports github.com/systemd/systemd/labels/needs-better-log-message but I need to test it with the latest version first...
    – Ben Creasy
    Oct 5, 2017 at 7:27
  • 1
    THIS!! when you try to do a systemctl daemon-reload without root, it will report a weird error like this. Just check if it is missing the sudo or executing in the correct user or you enabled the root execution (in ansible the become: true)
    – higuita
    Feb 23, 2018 at 19:46
1

This has been reported in this issue and fixed in this commit, which was released in systemd v244.

...but unfortunately this change will never go back to Centos 7's systemd v219.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .