1

I have this new computer (MSI Ge70 2PE Apache Pro) that came with Windows 8 and UEFI. I made a partition to install Debian testing 64bits on the same HD where Windows is. I had no problem making the partition but after that I tried making a bootable usb to install Debian and it didn't work. So I tried with an install dvd and even when I changed the boot order in the bios it didn't work.

After reading some more I realized that there could be a problem trying to boot a normal installation dvd with UEFi so I disabled Secure Boot and then switched the boot mode on my Bios to UEFI with CSM. Again it didn't work and it booted directly into Windows. So I switched the boot mode to Legacy. This time Windows didn't boot directly but I get a "Reboot and Select proper Boot device" message on a black screen.

No matter what I do I can't get the dvd to boot to install Debian. Any ideas what should I do?

Edit:

This is was an embarrasing layer 8 problem. I was trying to install this iso debian-testing-ia64-DVD-1.iso which has compatibility problems with many motherboards AND is a live CD not a debian installer iso. I downloaded the debian net installer and that solved the issue.

1

You should build your own Debian image according to the instructions contained in this link:

Debian UEFI-BIOS Compatibility

I've done this before, following this exact guide. Let me know if you have any questions.

  • Sorry, I was trying to understand the indications on that link but they're kind of confusing to me. I'm pretty new to Linux and, overall, on making dual boot configurations. So I have the usb drive that I'm going to use and I formatted it as gpt. Now I have to create two more partitions within the usb drive? the BIOS boot partition and the EFI System Partition? Am I understanding this correctly? But then it says that I have to mount the second partition on /boot/efi, but where should /boot/efi be? – Atirag Sep 30 '14 at 21:14
  • I'm not sure I am understanding your question. /boot/efi as the path sounds about right to me... I'll come correct with clarification after I get home. – Tyler Maginnis Sep 30 '14 at 23:17
  • Okay, I see where you are getting lost on this issue now. The goal here is to build GRUB Boot-Loader with support for UEFI devices. Replacing the Master Boot Record (MBR) with a UEFI compliant bootloader will solve this problem. This is sort of tricky for me to answer, because I don't know what kind of tools you have at your disposal. You're at least going to need some kind of Linux environment affect these changes to your disk. – Tyler Maginnis Sep 30 '14 at 23:42
  • Yes sorry I was not clear enough. This /boot/efi/ path is it within the usb drive? that means I have to mount the EFI partition that is on the usb on the /boot/efi path on the usb? Should I create this /boot/efi path within the contents extracted from the Debian iso? – Atirag Sep 30 '14 at 23:44
  • I am on a Linux environment.Debian. – Atirag Sep 30 '14 at 23:45
0

This is a very interesting FOSS-support problem. UEFI BIOS enabled motherboards tend to be problematic. This really can't be as bad as the Power-VR graphics support issue I solved earlier this year, and I seriously doubt we will be requiring any kernel hacking, as this issue is with GRUB.

I am aware that you are requiring dual-boot capabilities.

Therefore, one partition will be GNU/Linux, and the other partition, will host your Microsoft O/S.

The first step you require:

http://www.rodsbooks.com/refind/getting.html

Avast! Acquire rEFInd Boot Manager. Grab the CD ISO or USB stick. If you're going to do it on the USB stick, that's another, "can of worms," as it were, but I would be happy to guide you through the process of installing USB boot-able media on Linux.

The second step you require:

Load out troops! Stick that media in the broken system, and boot off it! rEFInd will check to see you have Linux installed. Select a Kernel to boot!

The third step you require:

Now that you're in a workable Environment on the system, check that your EFI system partition is mounted to /boot/efi

i.e., mount /dev/sda1 /boot/efi

But don't be so hasty! Check your mounting.

mount -l

Show me the output and I will help you determine if this parition even exists.

Check that your computer booted in EFI mode...

[ -d /sys/firmware/efi ] && echo "EFI" || echo "Legacy"

Should return "EFI."

Reinstall the grub-efi package

$> apt-get install --reinstall grub-efi

Install bootloader /boot/efi

$> grub-install /dev/sda

The bootloader should now exist at /boot/efi/EFI/debian/grub*ARCH.efi

$> efibootmgr --verbose

You'll likely know if this process has worked based on the output of the last two steps.

If this process fails, then the firmware on your device did not enter the information into NVRAM. Please make sure your BIOS settings are configured for this (not sure how your board is on this tip.)

Please post-back the output of efibootmgr --verbose when you get there.

BEST LUCK EVER MY MAN.

  • Thanks a lot for the detailed answer! but this doesn't work for me since I can't get to a Linux environment on the computer I need to install Linux on. That's part of the problem. I only have Windows 8 installed right now. – Atirag Oct 1 '14 at 15:02
  • I'm glad you found the issue. Now, I should have addressed the media. Which ISO you are going to be using is a very important consideration for your, "Requirement," as it were. – Tyler Maginnis Oct 2 '14 at 2:19
0

This is was an embarrasing layer 8 problem. I was trying to install this iso debian-testing-ia64-DVD-1.iso which has compatibility problems with many motherboards AND is a live CD not a debian installer iso. I downloaded the debian net installer and that solved the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.