4

I'm trying out the GNOME 3.14 live ISO and I would like to test multi touch gestures as well as Wayland session.

The promotional video shows multitouch gestures to zoom in and out, show the overwiev, switch workspaces etc. I've tried them but nothing seems to work on my trackpad (CyPS/2 Cypress Trackpad).

Also I cannot see a wayland session from the login page.

Is that possible to test any (or both)?

1 Answer 1

4

As far as i can tell, the gestures support in Gnome 3.14 are limited to touch-screen devices such as tablets, touch-enabled laptops, etc. According to the developers, gesture support for touchpads and trackers will be added in the next version (Gnome 3.16). Relevant links:

https://help.gnome.org/misc/release-notes/3.14/

https://wiki.gnome.org/Design/OS/Gestures

It is difficult to enter a wayland session from the live ISO image as the gnome-session-wayland-session package is not present in the live image. This has to be installed after which you will have to restart gdm with the session set as gnome-wayland. Detailed instructions are provided in this reddit post.

10
  • Thank'you very much. I'm gonna try it tomorrow morning and give a feedback
    – lviggiani
    Oct 1, 2014 at 19:03
  • Unfortunately it did not work. Fisrt I had to use yum instead of dnf. Then starting gnome-session manually did not work. So I used sudo systemctl start gem, log in, created a new user with password. Got back to gdm login screen, selected the new user and selected "Gnome on Wayland". But unfortunately, after entering the password it goes back to GDM login page again.
    – lviggiani
    Oct 2, 2014 at 13:16
  • That sounds weird... I haven't actually tried it out myself. Have you checked driver compatibility? Only the open-source drivers currently support Wayland. If it still persists, i guess a better option would be to actually install Gnome 3.14 on a system and check it out... :(
    – fijas
    Oct 2, 2014 at 19:15
  • I've and intel video card (Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)) that should work with the open source driver...
    – lviggiani
    Oct 7, 2014 at 7:40
  • Just to be sure, did you follow these exact steps: 1. Boot from Live CD. 2. Ctrl+Alt+F2 3. sudo systemctl stop gdm 4. sudo yum install gnome-session-wayland-session 5. gnome-session --session=gnome-wayland Nothing more and nothing less? For each boot of the live cd, you will have to re-install gnome-session-wayland-session. Let me know how it pans out...
    – fijas
    Oct 7, 2014 at 8:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .