1

I have a problem with my wifi internet connection that is secured by WPA. I have moved to a new location. I had set up a working internect connection but lost the connection after about an hour and this has happened more than once. I cannot simply reboot and run the same commands again as it does not work. The last thing that worked was setting up a minimal configuration file and then start it:

wpa_passphrase MYSSID passphrase > /etc/wpa_supplicant/example.conf
wpa_supplicant -B -i interface -c /etc/wpa_supplicant/example.conf
dhcpcd interface

as it is discribed in the wiki. At first it works but then I got a sudden disconnect and since then I just cannot reconnect even after several reboots. I have tried wifi-menu and netctl as well. I do not get any error messages and after running dhcpcd I have got a ordinary IP, the gatway and DNS are similar to the output on other machines that have a conenction. My windows phone and Win7 has no conenction problems. And before that I never had any problems with that. The only thing is that there now is no IPv6 Routers available.

Edit: lspci gives me:

Network controller: Intel Corporation Centrino Wirelss-N 105 (rev c4)

lsmod gives me:

Module     Used     Used by   
iwlwifi    1        iwldvm
cfg80211   3        iwlwifi, mac80211, iwldum

If I change my mac address I get another IP. I cannot ping anything and and cannot get pinged by others. The only thing I can do is ping myself. :D

Any help is appreciated.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.