1

I am trying to download a site as you see bellow with curl or wget but either one seems to work. I tried different options like "curl -k" seemed promising, but did not work. Every one is allowed to visit the page, it works with Firefox. I also check this page for answers but did not find one, although I think it is a similar problem.

--

curl "https://cdburnerxp.se/en/development"

0

Either it is a 403 page. You are not allowed. Or you can use a user agent such as this.

wget --header="User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_0) AppleWebKit/600.1.17 (KHTML, like Gecko) Version/8.0 Safari/600.1.17" http://website.com

It will allow you to access some websites. If this doesn't work then your are probably not allowed to visit the link.

10
  • Everyone is allowed to visit, it works with Firefox. If I do code(curl -k "notepad-plus-plus.org/news/") it works fine – andrej Sep 30 '14 at 6:23
  • Ok, did you try it with a user agent? – DisplayName Sep 30 '14 at 6:24
  • Sorry, what is a user agent? – andrej Sep 30 '14 at 6:27
  • It makes the the website think that you are on a browser. – DisplayName Sep 30 '14 at 6:28
  • I just tried code(curl --user-agent "Mozilla/4.0" "cdburnerxp.se/en/development") but it does not work. – andrej Sep 30 '14 at 6:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.