4

I'm on Arch Linux. HDMI output works fine with the gnome settings screen. But when I try to set it on a console using xrandr, arandr or lxrandr (xrandr --output HDMI1 --mode 1920x1080) all I get is an area of 1366x768 mirroring my laptop's screen on the top left of the TV and the rest of the screen is black.

At first I thought it could be a problem with the video card not being able to output two different resolutions (since doing that on some systems will lead to an upscaled 1366x768 picture on the TV), so I tried using xrandr --output LVDS1 --off to turn off the laptop's screen. It stopped outputting to the laptop's screen, but the TV was still the same.

The exact same thing happens on lxrandr and arandr, the output is shown as 1920x1080 but all I get is 1366x768 pixels on the top left of the screen, rest is blank.

I researched on this and couldn't find anything relevant, any help would be appreciated.

7
  • What is the maximum resolution of the Television?
    – eyoung100
    Sep 29, 2014 at 14:56
  • What happens if you first set the desired modes with the gnome settings screen and then run xrandr without parameters to get the current config? Sep 29, 2014 at 15:02
  • The max res is 1920x1080p, everything works fine on this resolution besides the console. @UlrichSchwarz I get the following: pastebin.com/jFZnPgLP Which is the exact same output as in the console, except that in the console HDMI isn't set as primary. Setting it as primary didn't fix the issue.
    – Ralph Snow
    Sep 29, 2014 at 15:55
  • What is it you want xrandr to do? All you've done is turned the display on at the set resolution. Mirroring your laptop's display is a perfectly valid option for xrandr to do with the display once it has been turned on. If you want it to do something else, you need to tell it what (and tell us what so we might be able to help you).
    – phemmer
    Sep 29, 2014 at 16:47
  • @Patrick The problem is that it's mirroring the 1366x768 image on a 1920x1080 screen, leaving the rest black. Here's a picture (sorry for the quality) so you get the idea: i.imgur.com/W694md2.jpg
    – Ralph Snow
    Sep 30, 2014 at 15:08

2 Answers 2

2

I know this is an old question, but in case anyone finds their way here and is looking for an answer, try using something like this:

xrandr --output LVDS1 --auto --primary --output HDMI1 --auto --same-as LVDS1 --scale-from 1920x1080

(adapt to suit your specific circumstances/requirements, of course!)

1
  • I don't remember how I fixed that back then, but the last time I tried doing this, about a month ago, I just did "xrandr --output HDMI1 --auto" and it worked.
    – Ralph Snow
    Nov 6, 2017 at 23:57
0

Another old answer but been having this issue for as long as I can remember across countless machines.

The answer for me was to set my preferred output (in my case HDMI-1) as primary BEFORE turning off other built-in displays that perhaps have a lower native resolution e.g. eDP-1/ LVDS-1 etc

I noticed that setting these things in a specific order in arandr worked, so my string in i3/config is now:

exec_always xrandr --output --primary HDMI-1 1920x1080 --output eDP-1 --off --output DP-1 --off --output DP.....

This also fixed an issue where feh would have a kind of repeated tile effect after manually adjusting the resolution.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .