2

I am using Trisquel GNU/Linux 6.0.1 (a modified version of Ubuntu) on the XFCE desktop environment. I am trying to record the output of my speakers. I do not have a microphone, and so cannot use it for this purpose (and I don't want to, anyways, due to the loss of quality).

Yet no matter what program I use (I have tried with many different programs including Audacity, RecordMyDesktop, GNOME Sound Recorder, and parec), PulseAudio volume control shows that the running program is not detecting any input, and the resulting files contain no audio. It is definitely set to "monitor of built-in analog stereo".

In case it's relevant, the output of arecord -l is

**** List of CAPTURE Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC270 Analog [ALC270 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Audacity shows this device as a recording option, but using it as input produces the same null results.

6
  • Is alsamixer unmuted?
    – eyoung100
    Commented Sep 29, 2014 at 0:39
  • @eyoung100 I went to alsamixer and found that the "speaker" setting and a few other things were muted (I was listening to headphones, after all). I unmuted everything, unplugged the headphones, and recorded. Again, the file was blank.
    – EMBLEM
    Commented Sep 29, 2014 at 1:14
  • You need to leave them unmuted, and set the recording device to the speakers and plug them into the mic input... the issue is tho that nothing is now in the speaker input
    – eyoung100
    Commented Sep 29, 2014 at 1:19
  • @eyoung100 I have no speakers; I'm on a laptop. How do I set the recording device as such?
    – EMBLEM
    Commented Sep 29, 2014 at 1:25
  • You need to use your Desktop Environments Equalizer/Mixer to set the inputs Set the recording input to Speakers. The issue here is that once the speakers are set as the recording pickup, you can't generate sound using the same speakers.
    – eyoung100
    Commented Sep 29, 2014 at 1:35

1 Answer 1

1

@eyoung100's comments helped me find the solution on my own. In PulseAudio volume control's "Input Devices" tab, ensure that "Monitor of Built-in Analog Stereo" is not muted.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .