6

I am trying to install ap-hotspot on Ubuntu-14.04

When I enter the command:

sudo add-apt-repository ppa:nilarimogard/webupd8

It gives me this message

"Cannot add PPA: 'ppa"nilarimogard/webupd8' Please check that the PPA name and format is correct"

How do I proceed?

Since I am using college proxy to access the Internet, so I tried

sudo -E add-apt-repository ppa:nilarimogard/webupd8

but it didn't help. But I am able to run

sudo apt-get update

so there is no problem with the internet connection. I also tried reinstalling ca-cerficates by using the command

sudo apt-get install --reinstall ca-certificates

it also didn't solve the problem. I also tried from Ubuntu Software Center, but there I am also unable to add a PPA repository.

please help me in resolving this problem...

  • Add the following lines manually to your software sources config: deb http://ppa.launchpad.net/webupd8team/unstable/ubuntu trusty main deb-src http://ppa.launchpad.net/webupd8team/unstable/ubuntu trusty main If you're using 14.10 change trusty to utopic – eyoung100 Sep 26 '14 at 14:02
  • @eyoung100 Thank you, I tried adding above lines in etc/apt/sources.list but when i run `apt-get update', It gives error "W: GPG error: ppa.launchpad.net trusty Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY C2518248EEA14886" I am using Ubuntu 14.04. – Vijay Singh Sep 26 '14 at 16:33
  • Visit the PPA here. Click Technical Details, try adding it again, if the same error repeats ignore the error. – eyoung100 Sep 26 '14 at 16:43
  • Thanks @eyoung100, Now,I am able to install ap-hotspot . – Vijay Singh Sep 26 '14 at 17:01
  • np. Would you like me to add an answer? – eyoung100 Sep 26 '14 at 17:02
9

Since you can't add the repository, you can always add them from a terminal using the command line. Browse to the list of the repositories at the WebUpd8 Website. Copy down the address of the master repository, which is Master Repository. You want to add this one because it contains all the others.

  1. sudo cp /etc/apt/sources.list /etc/apt/sources.list.backup
  2. sudo gedit /etc/apt/sources.list
  3. Visit Master Repository in a Web Browser.
  4. Find the Dropdown Arrow that reads:

    Technical Details about this PPA

  5. Click Your Ubuntu Version in the List Labeled Choose Your Version
  6. Add the resulting output into the file in Step 2.
  7. Save the File
  8. sudo apt-get update. This update command should now fetch the Private Keys of the new Repository. If you receive the error as you stated in your comment, then this repository has no private key. You may want to contact the PPA maintainer at that point who will either give you the key, or tell you to ignore the Warning.
0

I have faced this issue while installing Oracle JDK on my Ubuntu 16.04 machine.So after few search, I found a solution that really worked. We just need to add software properties and then we can install Oracle JDK on our Linux machine. Follow below steps

Step-1 Open terminal Ctrl + Alt + T
Step-2 sudo apt-get install software-properties-common
Step-3 sudo add-apt-repository ppa:webupd8team/java
Step-4 sudo apt-get update
Step-5 sudo apt-get install oracle-java8-installer

This package will run an installer for The Oracle JDK 8, which is the current stable release. You may also replace java8 in the package name with java7 or java9 to install different versions, although these releases are not recommended for development.

Verify that Java and the Java compiler have been properly installed:

Step-6 java -version or javac -version

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.