3

In my Xfce in Linux Mint when I press Ctrl+Shift, the keyboard language changes for the whole system, not just for the currently selected window. This is very uncomfortable.

How can I set up Xfce, so that the language only changes in the currently selected window?

The layout selection dialog looks like this:

XFCE keyboard layout selection

2
  • Maybe, kbdd is what you need.. github.com/qnikst/kbdd
    – user85611
    Sep 26 '14 at 13:56
  • Should this the changed keyboard language be kept associated with the window upon selection of another window? What would need to happen when you have multiple terminals in one window in multiple tabs, each their own language I presume?
    – Anthon
    Sep 26 '14 at 15:02
3

The standard XFCE keyboard layout tool is basically a GUI frontend for setxkb and as far as I know only allows you to switch layouts globally. If you want per application/window settings try xfce4-keyboard-plugin, set "Manage layout" from "globally" to "per window" or "per application":

keyboard layouts plugin

2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.