1

My laptop is DELL Latitude D600 (very old model, I don't know if this is related). I use Ubuntu 12.04 LTS with xmonad. This problem is weird.

In pavucontrol, under "Output Devices" tab, there is a "port" combo box with four options:

  • Headphones / Amplifier
  • Headphones / No Amplifier
  • LFE on Seperate Mono Output / Amplifier
  • LFE on Seperate Mono Output / No Amplifier

The problem is that when I plug or unplug my headphone, the option doesn't change at all. However, the sound always comes out from the correct device. If this doesn't make sense to you I will provide two example below.

  1. Before I plug in my headphone I am using the laptop speaker with volume 30%, with option "LFE on Seperate Mono Output / Amplifier" active. After I plug in my headphone, the active option is still "LFE on Seperate Mono Output / Amplifier" in pavucontrol, and the volume is still 30%. The sound comes out from the headphone instead of the speaker. The problem is 30% is too loud for the headphone.

  2. Before I unplug my headphone I am using the headphone with volume 3%, with option "Headphones / No Amplifier" active. After I unplug my headphone, the active option is still "Headphones / No Amplifier" in pavucontrol, and the volume is still 3%, which is too little for the laptop speaker to make any sound.

I hope the profile can change automatically, like it usually does in Ubuntu and Windows, so I don't need to open pavucontrol everytime after I plug/unplug my headphone or speaker. I am not sure why this happened. Did I forget any daemon program in the auto-start list?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.