0

I've just installed Debian Jessie and I'm trying to get systemd to do basic power management.

systemctl suspend and systemctl hibernate works well to suspend and hibernate the system.

Now, I want the computer to hibernate when I press the power button so I've edited /etc/systemd/logind.conf to contain:

HandlePowerKey=hibernate

Pressing the power button works to hibernate and if I press again the system resumes. But after resume tint2, tilda (that are always open) and any other applications that were open before hibernation are completely frozen. The mouse still works and I can open new applications but the applications that are frozen can't even be killed.

To test whether hibernation is the problem I've tried pressing the power button with this in logind.conf:

HandlePowerKey=ignore

The computer doesn't hibernate but the applications freeze the moment I press the button!

I've also tried with the line "HandlePowerKey" line commented out (the default option). That just causes the computer to shut down instantly.

I'm guessing that either:

a. logind.conf does more that the specified action (eg. hibernate, ignore) or:

b. Something else registers that I press the power button and meshes things up. Note that I don't have acpid installed.

What is at fault? How do I troubleshot the issue further?

  • I am definitely going to go with (b). – CameronNemo Sep 26 '14 at 2:16
  • What besides acpid could lay claim on the power button? – MajorBriggs Sep 26 '14 at 9:33
1

This error was caused by openbox.

Stupidly I left this in ~/.config/openbox/rc.xml:

<keybind key="XF86PowerOff">
  <action name="Execute">
    <command>sudo pm-suspend</command>
  </action>
</keybind>

The config file is a reuse from when I used acpid which overruled the keybind so I'd forgotten all about it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.