I'd like to use zfs with my Fedora 20 system.

I've installed the ZFS on Linux Fedora repository and subsequently the kernel-devel and zfs package. As far as I can tell, everything was installed successfully and I also rebooted the system. Nonetheless, sudo zpool create outputs errors:

Failed to load ZFS module stack.
Load the module manually by running 'insmod <location>/zfs.ko' as root.

Modprobe will also not load the module:

$ sudo modprobe zfs
modprobe: ERROR: could not insert 'zfs': Required key not available.

insmod with either of the two locations of zfs.ko I found on my system yields the same error:

$ sudo insmod /usr/lib/modules/3.16.3-200.fc20.x86_64/extra/zfs.ko
insmod: ERROR: could not insert module /usr/lib/modules/3.16.3-200.fc20.x86_64/extra/zfs.ko: Required key not available
$ sudo insmod /var/lib/dkms/zfs/0.6.3/3.16.3-200.fc20.x86_64/x86_64/module/zfs.ko
insmod: ERROR: could not insert module /var/lib/dkms/zfs/0.6.3/3.16.3-200.fc20.x86_64/x86_64/module/zfs.ko: Required key not available

I'm booting with UEFI, having SecureBoot enabled.

I guess the kernel will only load modules that are signed with some trusted keys, probably those of the Fedora kernel team. For example usb-storage apparently has such a signature:

$ modinfo usb-storage | grep '^sig'
signer:         Fedora kernel signing key
sig_key:        55:46:C1:1D:28:CF:EC:0B:46:B1:C1:F1:93:0D:6B:F3:EC:63:B0:67
sig_hashalgo:   sha256 

What can I do to get ZFS running?

Edit: I've tried to disable Secure Boot and I could in fact load the module without a problem. I don't like it as a solution, as Secure Boot does provides some additional protection and my BIOS/UEFI delays my boot process to tell me it was booting insecurely.

  • 2
    Your on the right track your module need to be signed, but this will probably never happens, so the only solution I see is to disable secureboot – Sir l33tname Oct 8 '14 at 6:08
  • Can you check output of following command ? - cat /proc/keys (This will list the keys registered in your system) - dmesg | grep -i "Loaded x.509" It might be the case that probably the module signing verification failed for zfs. I think that your dmesg or syslogs will be having errors like : "Request for unknown module key" – shubham Dec 15 '15 at 8:33

Turn off secure boot, or sign the ZFS and SPL modules.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.