1

I'm not necessarily looking for a solution, although that would be great... mainly an explanation.

On a MacBook 1.1 using rEFInd boot manager, if I boot Mint 17 Cinnamon 32-bit via the Grub bootloader, my keyboard works fine. If instead, I use rEFInd to select the vmlinuz kernel (with EFIstub support) for Mint 17, the keyboard doesn't work at the Mint login screen.

I've tried passing various individual parameters to the kernel, via rEFInd based on recommendations for other hardware: iommu=soft iommu=pt acpi=off

I noticed that grub seems to pass $vt_handoff so I tried that as well.

All had no apparent effect on the keyboard; it still didn't work.

Of possible relevance, the kernel and initrd live on a ext4 partition, so rEFInd is using additional drivers to read them for EFI-stub booting. grub.efi is on my ESP (Fat32) and my firmware requires no additional drivers to read it.

What can I do to diagnose this problem? What might be the cause?

0

From tips on Booting Linux inside a MacBook using grub and EFI:

In Debian/squeeze you may need to load some modules quite early (in particular if you have a crypted root partition: otherwise the keyboard will not work at the moment when the initrd will ask you the password). To this end, append to the file /etc/initramfs-tools/modules these lines:

#as suggested by http://grub.enbug.org/TestingOnMacbook
fbcon
#and I would further add 
hid_apple
hid
applesmc
input_polldev
#moreover  Vladimir 'phi-coder/phcoder' Serbinenko
#told me also to add
uhci_hcd
ehci_hcd
ohci_hcd

then regenerate the initrd

update-initramfs -u

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.