5

I'm running Fedora 20 with Gnome 3.12. Recently, I installed KDE via yum but decided to stick with Gnome. Ever since installing KDE, the xdg-open and gnome-open commands do not open files with the associated applications but will instead open Nautilus, selecting the file. Double-clicking the file in Nautilus will then open the associated application.

For example:

[user@host ~]$ xdg-mime query filetype test.pdf
application/pdf
[user@host ~]$ xdg-mime query default application/pdf
evince.desktop
[user@host ~]$ xdg-open test.pdf
[user@host ~]$ gnome-open test.pdf

but both of the last two commands open Nautilus. On the other hand, kde-open does work, opening evince (and writing some kioclient stuff to stdout, don't know whether that's of any relevance):

[user@host ~]$ kde-open test.pdf
kioclient(27111) KMimeTypeRepository::parents: "/usr/share/mime/subclasses"  refers to unknown mimetype  "application/vnd.ms-excel.sheet.binary.macroEnabled.12" 
kioclient(27111) KMimeTypeRepository::parents: "/usr/share/mime/subclasses"  refers to unknown mimetype  "application/vnd.ms-excel.addin.macroEnabled.12" 
kioclient(27111) KMimeTypeRepository::parents: "/usr/share/mime/subclasses"  refers to unknown mimetype  "application/vnd.ms-powerpoint.slideshow.macroEnabled.12" 
kioclient(27111) KMimeTypeRepository::parents: "/usr/share/mime/subclasses"  refers to unknown mimetype  "application/vnd.ms-excel.sheet.macroEnabled.12" 
kioclient(27111) KMimeTypeRepository::parents: "/usr/share/mime/subclasses"  refers to unknown mimetype  "application/vnd.ms-powerpoint.presentation.macroEnabled.12" 
kioclient(27111) KMimeTypeRepository::parents: "/usr/share/mime/subclasses"  refers to unknown mimetype  "application/vnd.ms-word.template.macroEnabled.12" 
kioclient(27111) KMimeTypeRepository::parents: "/usr/share/mime/subclasses"  refers to unknown mimetype  "application/vnd.ms-excel.template.macroEnabled.12" 
kioclient(27111) KMimeTypeRepository::parents: "/usr/share/mime/subclasses"  refers to unknown mimetype  "application/vnd.ms-powerpoint.template.macroEnabled.12" 
kioclient(27111) KMimeTypeRepository::parents: "/usr/share/mime/subclasses"  refers to unknown mimetype  "application/vnd.ms-word.document.macroEnabled.12" 
kioclient(27111) KMimeTypeRepository::parents: "/usr/share/mime/subclasses"  refers to unknown mimetype  "application/vnd.ms-powerpoint.slide.macroEnabled.12"

I'm aware of this thread, but using the mimeopen command did not solve my problem.

I didn't uninstall KDE so far because I'm not sure exactly how and I don't want to break stuff. However, any solution involving getting rid of KDE would be acceptable given some pointer as to how.

closed as off-topic by Pandya, Jeff Schaller, mdpc, Stephen Kitt, roaima Mar 10 '16 at 17:42

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Pandya, Jeff Schaller, mdpc, Stephen Kitt, roaima
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Have you installed xfce or check whether exo-utils installed? removing it may help you. (visit similar stuff: this and this). If this may help, let me know to add answer – Pandya Mar 10 '16 at 14:39
  • 1
    Thanks for your comment. Some update of Fedora along the away apparently fixed the issue for me, though. – Jonas Mar 10 '16 at 14:45
  • ok. no-probem if it is fixed – Pandya Mar 10 '16 at 14:48