2

I'm trying to use simple-cdd to create an complete unattended install of debian.

I have created a preseed file that gets used - but the installer is still asking me three questions

What is my region or continent? What is my country? What is my keyboard?

I have tried combinations of setting the locale in both the profile's conf file and in the preseed file - but these three questions still get asked.

I've seen it hinted that these question must be supplied as boot parameters as the preseed file does not get loaded until these questions are answered.

Is there a way to auto-answer these files?

2

According to the website http://sources.debian.net/src/simple-cdd/0.5.0/README/ to preseed these answers, you should pass the --locale parameter to the build-simple-cdd command

Language and Country Selection

to pre-select the language and country, it is recommended to use the --locale
commandline option:

 build-simple-cdd --locale en_US
  • Unfortunately, the debian installer still asks for the keymap - so only 2/3rds solved :-( – james Sep 24 '14 at 16:45
  • Try priority=critical on the kernel command line. – umeboshi Jan 25 '15 at 21:22
  • The current release (stretch) also has a --keyboard option – morloch May 31 '18 at 0:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.