I am a corporate user with proxy server. I am working on the Fedora 20 OS and installed Chrome browser.

I set proxy settings under Settings -> Network -> Change Proxy settings -> Network Proxy.

Where I have given my proxy setting in the HTTP Proxy.

PFA image enter image description here

But I am not able to access a website via HTTPS and It takes time to load and finally it returns website not found.

Do I need to change anything through system wide? If so, how?

closed as too broad by maxschlepzig, Ramesh, Anthon, Networker, Flup Sep 24 '14 at 8:06

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    It's is difficult to help you as we don't know your companys network setup. Perhaps you have to add the proxy also to the HTTPS proxy. – Uwe Plonus Sep 23 '14 at 7:07
  • Yes.I have added the same in the HTTPS. But it ends up with a message "Your connection is private" with error code NET::ERR_CERT_AUTHORITY_INVALID. This issue only on the Chrome browser. On the same time, i can able to access in Opera without any issues. (In Opera, I get certificate alert box if i access https website). That too not happened in the Chrome browser. – Raja Sep 23 '14 at 7:21
  • 2
    Your HTTPS proxy inserts its own certificate. Some firewalls do this in order to perform layer-7 scans on HTTPS traffic. Chrome rejects bad certificates like that out of hand, Safari just warns. – Shadur Sep 23 '14 at 8:00

To enable browsing of HTTPS sites you have to add the proxy also to the HTTPS proxy settings.

Also you have to import the root CA of your companys proxy to chrome else chrome will not accept any connections as it does not know the root CA.

Also be aware that you will not be able to display some sites as chrome is using Certificate pinning for some sites (e.g. https://www.google.com).

The certificate pinning is done to prevent Man-in-the-Middle (MitM) attacks. Using a https proxy is basically a MitM attack as your secure connection is broken up at the proxy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.