I'm having a problem with printing pdf files. When I try to print them in the default mint's document viewer everything seems to work but my printer is stuck with the "Processing please wait" message. It displays this message for a few minutes then goes to the main menu without printing anything. When I the job's attributes in the printer's preferences it shows in real time that the printer is printing pages 1,2,3,4 etc. I thought it means that the printer is processing each of these pages and it will print them afterwards but it didn't.

Then I tried xpdf and it did print everything without any problems. Then I tried other pdf viewers but only xpdf was able to print it. The problem with xpdf is that it creates a lot of jobs instead of one(is this even normal?) and the printing setup menu is very minimalistic. It's not even possible to print on both sides and 2 pages per side. Then I tried the command lpr:

lpr -p -o sides=two-sided-long-edge -o outputorder=reverse -o number-up=2 abc.pdf

Which should print on both sies with 2 pages per side and in reverse order. There are no errors but my printer is stuck with the same message as before and it doesn't print anything. Like before, in the job's attributes it shows that the printer is printing each page and after the last one the job is "done". But nothing is printed! What can I do?

  • 1
    Are you also using CUPS? – eyoung100 Sep 22 '14 at 16:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.