2

I admit I don't update my kernel very often. I used to everytime a stable release of sys-kernel/gentoo-sources came out so I'm very adept at doing it. This last weekend I attempted to update from 3.12.13 to 3.14.14. Over this past weekend, I was able to update with one MAJOR ANNOYANCE. More on that after my configuration:

  1. Kernel: 3.12.13-gentoo
  2. Initial RAM Disk Creator: sys-kernel/genkernel-next-58
  3. Video Drivers: uvesafb for frame buffer and x11-drivers/nvidia-drivers-343.22 for XOrg Server/KDE. I need the nvidia-drivers for Eve Online. AFAIK, nouveau won't work with Eve.
  4. Init System: sys-apps/systemd-215-r3

TL;DR. See bolded Question

After Setting the Appropriate Settings in /etc/genkernel.conf(I set PLYMOUTH to YES, PLYMOUTH_THEME to tribar), I used eselect kernel set to set the kernel soft link to 3.14.14 and used genkernel all to build everything. I ran grub2-mkconfig, I rebooted and realized I built the wrong network driver(ath5k instead of ath9k), and that I hated tribar. Saturday morning, I replaced tribar with solar, removed and replaced ath5k with ath9k, reran genkernel all/grub2-mkconfigand rebooted...


To my odd surprise I received 2 ASCII Squares, and a Percentage Sign repeating 3 times instead of the solar theme. I double checked my terminal commands and reran them in sequence with the same result. I double checked the conf files too. /etc/plymouth/plymouthd.conf contained solar, same with the /etc/genkernel.conf file. I ran genkernel initramfs in KDE/kterm so I could scrollback, and I saw the solar theme files copied into the RAM Disk.

The oddest part of all is that even though all the files are copied into the RAM Disk correctly, if I put tribar in all the appropriate files again, plymouth will show tribar correctly. 2 Ascii boxes and 1 percentage sign equals 1 of the tribars. As such, why is plymouth still showing the tribar theme when I told it to use solar? I know this should work correctly because I still have my old kernel that I set up to use the spinfinity theme when I first switched over to grub 2 and systemd. If I boot with it, I see the spinfinity theme.

On a side note, I do see a warning during boot on the new kernel about systemd not being able to write to /tmp because /tmp isn't empty. Could this be part of the problem?

Signed,
Experienced but Frustrated

  • have you tried unpacking your ramdisk and verifying that the solar files are really there? (I know it said it copied them, but maybe there was a problem.) – strugee Nov 20 '14 at 20:50
  • @strugee I've got Genkernel-next's logging set to 5, which is the highest level of verbose, but I'll check that tonight... – eyoung100 Nov 20 '14 at 20:53
  • Not familiar with gentoo mechanisms, but you need to set the theme and also rebuild your initrd. Assuming gentoo also uses dracut, please have a look at wiki.archlinux.org/index.php/plymouth Maybe you should move your manually-edited initrd away, and recreate one from scratch via dracut. – doktor5000 Nov 27 '14 at 16:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.