1

OS is RHEL 6.2.

I appear to be having an issue with SELinux. I've disabled it in /etc/sysconfig/selinux, however, when my host starts the command sestatus show that I'm in permissive mode.

Searches in Stack Exchange bring me to this U&L Q&A: How to permamently disable SELinux?. That question mentions a scenario that sounds similar to mine.

Which prompted me to have the following questions:

  1. what does net.ipv4.tcp_syncookies=1 (=0) means?
  2. Is it safe to turn to this to 0?

NOTE: My original problem is related to automount/nfs.

Sometimes when a distant Filesystem is neither mounted nor unmounted, we have to restart autofs. I don't know if this is happening under heavy traffic or if this issue is related to the net.ipv4.tcp_syncookies problem above or not.

So I'm trying to get a better understanding of net.ipv4.tcp_syncookies so that I can ascertain whether this is related to my autofs problem or nott.

  • What does the SELinux bit have to do with your 2 questions? As it stands your Q is a bit confusing. If you can clean it up we can reopen it. – slm Sep 22 '14 at 12:57
  • @slm Searches in Stack Exchange bring me this: unix.stackexchange.com/questions/30342/…, on this page disabling selinux is related to net.ipv4.tcp_syncookies, I was just asking for precision. Sorry to have been unclear. – Archemar Sep 22 '14 at 13:03
  • OK, I think I see what you're asking now. I've edited the Q further and reopened. Thanks! – slm Sep 22 '14 at 13:08
1

net.ipv4.tcp_syncookies=1

Helps in preventing SYN flood attack on the system. A value of 0 will disable it.From security point of view, it is ideal to keep it on i.e. set value to 1. However, its pretty safe to turn it off.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.