I've just installed Linux Mint and I am wondering how to fully disable or uninstall the workspaces feature. I've already removed the Window Switcher applet from the bottom panel but this doesn't fully solve the issue. These are the things in particular that I want to remove:

  • Options to "Move to right workspace", "Move to Workspace 2", etc. in the context menu of the title bar
  • Any keyboard shortcut that involves switching workspaces or moving windows to different workspaces. In particular Ctrl + Alt+Up arrow
  • Anything else that can be accidentally triggered to create or switch workspaces.

I've already unchecked everything in Hot Corners but the keyboard shortcuts and context menu still show the workspaces-related options. This has got to be one of the most annoying features of any Linux Desktop Manager system and it's really baffling as to why it's still enabled by default or even present after all these years.

3 Answers 3


What I would do, and have done on my in-laws computer, is to open the "Workspace Switcher Preferences" (most easily accessible via the workspace switcher on the panel, before you remove it) and set the "Number of workspaces" to 1.

I don't recall whether this removes the "Move to Right" options etc., but it at least makes them useless. This is good enough for most users, unless you really want to remove all traces of the workspace functionality.

  • 2
    This will still open new workspaces when dragging window to a side. To fully disable, one should also remove all shortcuts at Settings > Window Manager > Keyboard and remove check marks from Settings > Window Manager > Advanced > Wrap workspaces when reaching the screen edge.
    – Yeti
    Sep 15, 2016 at 7:12
  • 1
    Additionally: Settings > Desktop > Menus, remove check marks with 'workspace'.
    – Yeti
    Sep 15, 2016 at 7:24
  • In Linux Mint, if you want to remove the shortcut so it's free for other applications, you need need to go to Settings > Keybpard > Shortcuts > Wordspaces and set different shorcuts for those two actions. You cannot simply nullify them, May 26, 2020 at 6:28

On more recent versions of Cinnamon (I'm on 4.6.7 in Linux Mint 20 currently, but I think at least the gsettings command applies to anything after 2.6):

In terminal

  • gsettings set org.cinnamon.desktop.wm.preferences num-workspaces 1 sets number of workspaces to 1, effectively disabling them.

In the Menu's Preferences -> Keyboard -> Shortcuts

  • under General category click "Show the workspace selection screen", double-click on the first shortcut (Ctrl+Alt+Up) and press Backspace to remove it
  • do the same in Workspaces for both "Switch to left workspace" and "Switch to right workspace".

Cinnamon Keyboard Shortcuts



All settings > Appearance > Behaviour > Uncheck "Enable workspaces"

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .