1

I have a quite weird problem I just cannot get rid off. I am using ArchLinux and as I am from Germany the german keyboard layout and such.

So when I start Gnome via startx it is said that Gnome is not able to work I must logout. I have get rid of this problem two times but just until I restart. After the rebot the same problem occurs and I am no longer able to use Gnome. I have get rid of the problem as long as I do not reboot but I do not excatly know what is causing this problem. First I get warnings from XKEYBOARD:

XKEYBOARD keymap compiler (xkbcomp) reports:
Compat map for group 2 redifined.
Compat map for group 3 redifined.
Compat map for group 4 redifined.
Using new definitions.
Type "ONELEVEL" has 1 levels, but <RALT> has 2 Symbols.

The it says:

xinit:Connection to X server lost

And my log file says the following, but I have shorten it:

[user@Work log]$ grep -e WW -e EE /var/log/Xorg.0.log.old
[  1281.385] Current Operating System: Linux Work 3.16.3-1-ARCH #1 SMP PREEMPT Wed Sep 17 21:54:13 CEST 2014 x86_64
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  1281.386] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[  1281.386] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[  1281.386] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[  1281.386] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[  1281.394] (WW) intel(0): Detected a hung GPU, disabling acceleration.
[  1281.395] (WW) intel(0): loading DRI2 whilst the GPU is wedged.
[  1287.428] (EE) Server terminated successfully (0). Closing log file.

Then I aslo found some posts on similar problems so I have added three files to the directory /etc/X11/xorg.conf.d. The first time this has solved the problem I guess, but it still does not work.

/etc/X11/xorg.conf.d/20-keyboard.conf

Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "de"
        Option "XkbVariant" "nodeadkeys"
EndSection

/etc/X11/xorg.conf.d/20-keyboard.conf

Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "de"
        Option "XkbVariant" "nodeadkeys"
EndSection

/etc/X11/xorg.conf.d/20-intel.conf

Section "Device"
   Identifier "Intel Graphics"
   Driver "intel"
   Option "NoAccel" "True"
EndSectio

And regenerate the locales with locale-gen.

Please help me, as I just do not know what to do anymore. :D

Running xfce4 without any problem.

0

So I have finally solved this problem. I needed to deinstall the xf86-video-vesa driver with:

pacman -R xf86-video-vesa

And then I needed to change the /etc/X11/xorg.conf.d/20-intel.conf file to:

Section "Device"
   Identifier "Intel Graphics"
   Driver "intel"
   Option "DRI" "False"
EndSection

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.