27

I'm using Xfce 4.10 with xfwm4 as my window manager. I'm finding it difficult to resize windows by grabbing the border. The region where the mouse cursor changes to the "resize window" cursor seems to be only 1 or 2 pixels wide, and I keep moving right through it.

How can I make that region a bit wider? I don't want to change the appearance of window borders, just make their hit target a bit wider. (I know about the Resize option in the window menu, but that doesn't allow you to resize a window in only 1 dimension.) I've looked in the window manager settings & tweaks, but I don't see any setting that appears to apply.

  • 1
    Question remains: How to change the width of the target zone near a window edge where the cursor will grab on to the edge? – HiTechHiTouch May 11 '17 at 23:25
26

It's very easy, you can use Alt + right-click + drag.

  • 2
    A technically correct answer which does not address the issue of the grab bar width. So we now have a GUI layout problem, because the window designer didn't make the grab are large enough. Good GUI principals use a change in the cursor/mouse over text when passing over different active areas where mouse actions will over the grab bar to indicate a change, and discourage using modifier keys such as ALT. The preferred solution from the GUI point of view, show a changed cursor in the active area, is sufficient. Novice users need not know of or remember modifiers & alternate clicks. – HiTechHiTouch Sep 17 '18 at 5:59
  • 1
    "Very easy" depends. Try this on a notebook with a touchpad... – karatedog Jun 30 at 18:28
12

Apparently this problem has been around for years, and one bug report has been closed "won't fix". The issue has been reopened with Bug 11808 - Xfwm: Increase the resize border of window.

The width of the grab area is controlled by the theme. Another circumvention is to try different themes until you find one you can live with. One developer has commented:

That is coded in the theme itself AFAIK, at least that's what we found out during MX-15 development. If you are using greybird (or bluebird) and a Debian-based distro, then you can take a look at our mx-greybird-themes package, where we expanded the border to 3 pixels after much tester feedback about how annoying it was to try to grab it. (We are about to update that BTW to include a Stretch version that fixes other appearance problems.)

Here is a blog entry about how themes set up the boarders.

Another post suggests something to change in the theme definition (and actually this file is not part of a definition, but the window manager), ~/.gtkrc-2.0

style "default-style"
{
        GtkWindow::resize-grip-height = 4
        GtkWindow::resize-grip-width = 4
}
class "GtkWidget" style "default-style"

gives me a smaller grip area. Increasing that number should give you a larger grip area. You will need to reload the theme for the setting to take effect.

I personally haven't tried altering the theme definition, but this looks like a good starting point.


Edited to add:

Another approach involves installing and configuring Compiz (the base package may already be present in recent distributions). I repeat it as it's part of a bug report and may get deleted as not "relevant" by the bug manager.

 tm.selsingen 2017-02-11 19:40:45 CET 


This may be a rough solution not suited for those needing xfwm4 because 
of limited system resources. But you can change the default window 
manager to compiz. This solved the issue for me and I can now enjoy the 
xcfe simplicity combined with generous grabbing areas. 

https://wiki.ubuntuusers.de/Compiz/ 

Enter in terminal: 

"sudo apt-get install compiz compiz-gnome compiz-plugins-extra" 

"sudo apt-get install compizconfig-settings-manager" 

"ccsm" _______________________ 

In CCSM you need to enable OpenGL, Composite, GNOME Compatibility in 
'General' Tab. Within the 'General Options' menu, you can set the focus 
steal prevention to zero, so that new windows are placed always on top, 
and choose your workplaces 

In 'Effects', enable Fading Windows, Window decorations, and if you like 
Animations 

In 'Other', you can enable Window previews (may need png) 

In Tools enable Compiz Library Toolbox, D-Bus, Mousepolling (gets 
activated if you choose Window previews), Session Management and 
Workarounds 

Now in 'Window Management', you need to choose Application Switcher, 
Move Windows, Place Windows, Scale Windows Put and Window Rules. 

Ring, Static & Shift Switcher are more advanced Application Switchers 
you can configure as you like. 

In the CCSM Settings you need to enable Gsettings Configuration Backend. 

________________________ 

Now Compiz is configured, make a Backup of 
"/home/user/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-session.xml" 
and enter 

"xfconf-query -c xfce4-session -p /sessions/Failsafe/Client0_Command -t 
string -sa compiz" 

in terminal to configure xcfe to use compiz as the default window 
manager. ________________________ 

To spare you from needing GNOME Tweak to set your theme now, you can use 

"gsettings set org.gnome.metacity theme insertyourthemehere" to change 
the window decoration theme 

and the default xcfe theme settings to change the rest of the UI. 

I experienced that my minimize/maximize Buttons were gone after that. 

you can use "gsettings set org.gnome.desktop.wm.preferences 
button-layout ':minimize,maximize,close,'" to restore them. 

And that's it. 

Comment 15 tm.selsingen 2017-02-12 09:11:22 CET 

I don't know how to edit posts, but I realized the desktop icon texts 
get displaced if you follow the steps. This is the fix: 

xfconf-query -c xfce4-desktop -p /desktop-icons/center-text -n -t bool 
-s false 
  • The "edited to add" approach seems to work most places, but not for Firefox. YMMV. – HiTechHiTouch May 12 '17 at 0:48
  • The window resize margin remains only one pixel wide in the Greybird theme, but at least in the Kokodi theme, which comes with XFCE (Ubuntu 18.04 + the xubuntu-desktop package), the margin is wider, and thus easier to use. – Teemu Leisti May 2 '18 at 0:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.