0

I have a computer with a Gigabyte GA-Z97N-Gaming 5 mainboard, a 256 GB drive for booting and two 3 TB drives meant to use in a RAID 0 setup with both ext4 and NTFS partitions. We are planning running Xubuntu 14.04 and Windows 8.1 on it.

Using dmraid seemed to limit the RAID volume size to 1.5 TB, so it was not feasible with 6 TBs of disk surface. Referring to an Intel whitepaper, I could configure a 6 TB-volume and create 4.5 TB ext4 partition using gdisk and mkfs.ext4, and an NTFS partition using Windows to the rest of the capacity.

So, the setup seems to work on both Linux and Windows as expected. However after rebooting Xubuntu, the /dev/md126[|p1|p2] devices will no more appear.

Here are the exact commands which were run in the successful setup

sudo mdadm -C /dev/md/imsm /dev/sd[b-c] -n 2 -e imsm
sudo mdadm -C /dev/md/vol0 /dev/md/imsm -n 2 -l 0
sudo mdadm -E -s --config=mdadm.conf > /etc/mdadm.conf
sudo gdisk /dev/md126 # created partitions
sudo mkfs.ext4 /dev/md126p1 
sudo mkdir /home/levo/megaosio
sudo nano /etc/fstab # added UUID->/home/levo/megaosio entry with defaults
sudo chown levo:levo /home/levo/megaosio/
sudo mount -a

First time the volume disappeared, I tried rebuilding the volume from scratch using following commands:`

sudo mdadm -C /dev/md/imsm /dev/sd[b-c] -n 2 -e imsm 
sudo mdadm -C /dev/md/vol0 /dev/md/imsm -n 2 -l 0

To my surprise, that made the ext4 and NTFS volumes appear again and I could access them.

I really do not believe that this is the correct way to make a volume appear. Have I missed a step when configuring the volume, or does booting to Windows or rebooting per se just ruin the metadata? What would be the correct way to discover the volumes on startup?

/etc/mdadm.conf contains

ARRAY metadata=imsm UUID=ff5cb77f:cf2f773b:3dc18705:11398139
ARRAY /dev/md/vol0 container=ff5cb77f:cf2f773b:3dc18705:11398139 member=0 UUID=cb1e53b2:e182f7c2:5f3d8a99:6663ffd6

sudo mdadm --detail --scan only returns a newline.

  • mdadm -C is definitely not correct for existing arrays; the way you tried to create your /etc/mdadm.conf seems wrong too. Does it exist, what does it look like, what does mdadm --detail --scan show? – frostschutz Sep 19 '14 at 10:36
  • Also, after changing mdadm.conf you might have to update initramfs, regardless whether your root filesystem is on the md or not. – frostschutz Sep 19 '14 at 10:38
  • I added contents of mdadm.conf and the fact sudo mdadm --detail --scan returns nothing to my question. – borellini Sep 19 '14 at 11:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.