I am trying to mount W95 FAT32 (LBA) partition type into /mnt/data on my Raspbery Pi B+. Therefore, I've created this parttion and the current partition table is as follows:Partition Table I've checked proc/filesystems for a list of supported partition types and here is a listing:Supported Files Systems. Now, I've tried to mount mmcblk0p3 partition as vfat and msdos type and I always get error:Mount Error What am I doing wrong?

  • 2
    Have you tried mounting without the -t option? It should auto-detect the filesystem. – garethTheRed Sep 18 '14 at 13:14
  • I have now, same error. – KernelPanic Sep 18 '14 at 13:16
  • Is mmcblk0p1 mounted/mountable? Anything in the logs? – garethTheRed Sep 18 '14 at 13:19
  • 2
    Does file -s /dev/mmcblk0p3 show that there's anything like a FAT32 filesystem there? – Mark Plotnick Sep 18 '14 at 13:21
  • @MarkPlotnick: I've tried that now, it shows: [root@octopus ~]# file -s /dev/mmcblk0p3 /dev/mmcblk0p3: data [root@octopus ~]# – KernelPanic Sep 18 '14 at 13:23

I have solved the problem. I've allocated empty space for partition using fdisk, but I did not make filesystem, format it and then mount it using mkfs.vfat /dev/mmcblk0p3 and mount -t vfat /dev/mmcblk0p3 /mnt/data. Now works ok!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.