13

I just installed Linux Mint 17 (MATE) on an old laptop and everything works amazing, however I can't seem to get it to connect to my WiFi network. All my other computers can get access, plus, before when the laptop has Windows XP, it could also find and connect. Is there a way to check if it's even detecting the correct network? If so, how would I set up a proper connection to the network?

There is nothing wrong with my network nor the laptop, so it must be Mint's fault.

Edit: Output of iwconfig:

lo       no wireless extensions.

eth0     no wireless extensions.

Output of lspci -nn | grep 0280:

02:04.0 Network controller [0280]: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller [14e4:4318] (rev 02)
  • Please edit your question and add i) the output of iwconfig and ii) the output of lspci -nn | grep 0280. – terdon Sep 18 '14 at 9:56
  • @terdon Edited and added. – Snowstormer Sep 18 '14 at 10:10
  • geez. fought with this issue for an hour. Alt-F2 enabled wireless. But it was color coded for the windows machine it used to be. Fn_F2 blue. grrr... – user96305 Dec 29 '14 at 1:52
5

This answer assumes that you can connect your machine to the network using a cable and so get internet access. If that assumption is wrong, let me know and I'll modify this.

You need to install the driver for your wireless card. The driver support table of the Linux Wireless page lists it as supported so you should be able to get everything working by simply running:

sudo apt-get install firmware-b43-installer

If this does not work leave me a comment, you might need to tweak it a bit.

Further reading:

| improve this answer | |
  • Thanks, I got the driver installed with an old cable I found laying around. Still, not sure how I can set up the WiFi network itself. I also did iwlist wlan0 scanning which told me: wlan0 Failed to read scan data : Network is down – Snowstormer Sep 18 '14 at 11:18
  • @GotGaming_ did you reboot? Did the iwconfig output change? – terdon Sep 18 '14 at 11:51
  • Yes, I did and it now shows wlan0 IEEE 802.11bg ESSID:off/any Mode:Managed Access Point: Not-Associated Tx-Power=off Retry long limit:7 RTS thr:off Fragment thr:off Power Management:off + the same 2 it showed earlier – Snowstormer Sep 18 '14 at 11:58
  • 1
    Oh I'm a dummy, I had WiFi turned off xD Thank you so much, I couldn't have done it myself. – Snowstormer Sep 18 '14 at 12:03
  • 1
    @terdon Without Ethernet, one can get b43-fwcutter from packages.ubuntu.com, and the driver from a computer with internet access. This post is useful for this scenario: askubuntu.com/questions/730799/… – John K Aug 10 '16 at 20:27
1

Applies to: Linux Mint 17.3

Because of an apparent bug, if you're using a Broadcom based WiFi card (such as BCM4321) on this edition of Mint, you need an internet connection already established, either from cable all by using an Atheros based USB Wifi dongle. (E.g. TP-722). At least this is so, if you attempt to install from a USB memory stick, made from an ISO using UNetbootin.

What should happen is that you get a screen under driver manager that look like the picture below, then you select the bcmwl-kernel-source and Mint should download and install the new kernel-driver from the USB memory and after reboot it should just work. This does not happen as the driver manager insists on network connection.

So instead find an alternative connection and install using driver manager.

enter image description here

In addition, please note that on some laptops (especially HP) there may be a manual WiFi switch. For some reason, even when on it is starting of as off, so you need to toggle that switch. You can check this status (if the drivers are properly installed) with:

# rfkill list
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: brcmwl-0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes

Then, once you've toggled, you should get something like:

# rfkill list
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: brcmwl-0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
2: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

If for some reason, it would show as soft blocked, you can run:

$ sudo rfkill unblock 1
$ sudo /etc/init.d/networking restart
| improve this answer | |
0

Execute the following two on the command line:

sudo apt-get install b43-fwcutter firmware-b43-installer
reboot
| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.