1

Background

I have an ssh and OwnCloud server. Frequently, my desktop's OwnCloud client disconnects. Attempting to ssh into my server results in Connection refused. I can ping the server, but cannot connect via ssh or the OwnCloud client. Oddly enough, I can connect to the OwnCloud webpage fine.

After several minutes, I can connect via ssh. However, I sometimes get kicked from the session, and cannot connect again for a few minutes. This just happened, allowing me to look through /var/log for newly-modified logs. The following had all been modified recently, but none contained anything interesting: wtmp lastlog auth.log ufw.log syslog messages kern.log.

After being locked out, I've also tried to restart, but this does not solve the problem immediately. In the past, I could always connect about 60 seconds after a restart. Now, I cannot connect for several minutes. As above, ping works, but I cannot connect immediately.

How can I make my ssh/OwnCloud server work all the time?

Other information

The server is a Raspberry Pi running Raspbian Jessie (testing). I also use ufw and fail2ban.

2

It seems that this problem was caused by another connected device competing for the same IP address. I'm not sure how it managed to confuse the router, but when I disconnected the other device (a Volumio Raspberry Pi), I could connect to the main server fine again.

0

I've used Raspberry Pi to run bunch of services to the device on Raspbian. If you have Owncloud running on the system, you have to ensure apache or sshd is running 24/7/365. From my understanding if the device overheats it starts to act funny like getting kicking off ssh while being connected. I was also aware that in my lab it started to get hot from the other computers so I had to cut a square on the device and installed a small fan purchased from Radioshack connected to the GPIO pins.

After rebooting couple of times it took care of the problem. Once the device is powered on and its stable you'll be able to make a SSH connection and stay logged in for days and months, maybe years.

Try this before you do anything. Get the units temperature details by issuing:

/opt/vc/bin/vcgencmd measure_temp

you can also add that to your alias:

cd ~

sudo nano .bash_aliases

alias temp='/opt/vc/bin/vcgencmd measure_temp'
  • This seems plausible, but when I ran that command, it returned temp=35.8'C, which seems very low. I'll try again when I get another ssh refusal (and subsequent reconnect), and report back. – Sparhawk Sep 18 '14 at 3:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.