4

I need some screen capture application for RHEL6.5 and tried few ways to get one but failed.

  1. yum install gnmoe-utils and got:

    Reading Local RPMDB rpmdb time: 0.000 Setting up Install Process Checking for virtual provide or file-provide for gnome-utils No package gnome-utils available. Error: Nothing to do

Q: Is there a repo or some other way to get it installed?

  1. yum install shutter

    Error: Package: shutter-0.93-1.el6.nux.noarch (nux-dextop)
       Requires: perl(JSON)
    Error: Package: perl-Net-OAuth-0.28-1.el6.noarch (epel)
       Requires: perl(Digest::SHA)
    Error: Package: shutter-0.93-1.el6.nux.noarch (nux-dextop)
       Requires: perl(Time::HiRes)
    Error: Package: perl-Net-DBus-0.33.6-8.el6.x86_64 (epel)
       Requires: perl(Time::HiRes)
    Error: Package: perl-HTTP-Server-Simple-0.43-1.el6.rf.noarch (rpmforge)
       Requires: perl(CGI)
    Error: Package: perl-Gtk2-1.248-1.el6.x86_64 (epel)
       Requires: perl(HTML::TreeBuilder)
    ..... more errors related to `perl`
    

Trying to get perl:

  COMMAND: yum install perl 
  Installroot: /
  Ext Commands:

     perl
  Setting up Package Sacks
  Running "exclude" handler for "security" plugin
  pkgsack time: 0.060
  Reading Local RPMDB
  rpmdb time: 0.000
  Setting up Install Process
  Checking for virtual provide or file-provide for perl
  Nothing to do

Q: How it can be resolved?

  1. Print Screen shortcut is not complaining for gnome-screenshot not found.

Q: How it can be installed?

Ultimately, I just need some application to get screenshots.

8
  • yum install gnome-screenshot may well install it for you :-) – garethTheRed Sep 17 '14 at 13:35
  • Tried that too and got this: rpmdb time: 0.000 Setting up Install Process Checking for virtual provide or file-provide for gnome-screenshot No package gnome-screenshot available. Error: Nothing to do – flamenco Sep 17 '14 at 13:42
  • Have you tried: yum install gnome*? – ryekayo Sep 17 '14 at 13:42
  • @ryekayo: Nope but I do now! It was moving but it stopped with this error: Error: failure: repodata/6e8ae16744b797090259a097b33c485e584aa52824f45968924cb7e9db9ca032-filelists.sqlite.bz2 from nux-dextop: [Errno 256] No more mirrors to try. You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest – flamenco Sep 17 '14 at 13:47
  • Hmmm I would try using the error messages advise to see if it can fully install. If not, check the website that has the software your looking for and see if you can use wget to get the package – ryekayo Sep 17 '14 at 13:49
3

If none of the other options are working you can use the command line to acquire screenshots too.

$ import screenshot.png

$ import -window root -resize 400×300 -delay 200 screenshot.png

This is part of ImageMagick. There's also scrot too.

$ scrot MyScreenshot.png

$ scrot -b -d 5 '%Y:%m:%d:%H:%M:%S.png' -e 'mv $f ~/Desktop/'

In this example,

  • -b specifies including the window borders
  • -d specifies a delay of five seconds
  • '%Y:%m:%d:%H:%M:%S.png' will save the screenshot with a name based on the current date and time and with the format specified, .png in this case
  • -e 'mv $f ~/Desktop/' tells scrot to save the screenshot to the Desktop

The above was heavily borrowed from this AU Q&A titled: What is the terminal command to take a screenshot?.

6
  • $ import screenshot.png -bash: import: command not found – flamenco Sep 17 '14 at 13:50
  • @flamenco - you'll have to install ImageMagick. sudo yum install ImageMagick. – slm Sep 17 '14 at 13:51
  • Checking for virtual provide or file-provide for ImageMagick No package ImageMagick available. Error: Nothing to do – flamenco Sep 17 '14 at 13:52
  • @flamenco - do this, repoquery -qf /usr/bin/import. – slm Sep 17 '14 at 13:55
  • I think so too. I'm new to Linux and do not know to much about rmp and yum. I got he idea how they work but as far where to look for repos and fine details, I do know to much. – flamenco Sep 17 '14 at 14:06
1

You may also try avconv:

$ avconv -t 1 -s 2024x768 -f x11grab -i :0.0+0,0 -r 0.5 -f image2 foo.png

May be a bit exaggerated, though. Note to adjust your desktop size as "2024x768" might not fit.

0

From the comments, it sounds as if you added a 3rd Party repo before registering with RHN. By doing so, every package on the system is treating the third party repo as all repos. Please:

  1. Remove the 3rd-Party Repo from /etc/yum.conf or /etc/yum.repos.d/redhat.repo
  2. Read all of Chapter 5: Registering a Redhat System
  3. Register the system as per Chapter 5.
  4. Re-add the 3rd party repo.

If those steps don't work, format and redo the install if possible. Once the install finishes, follow the instructions in Chapter 5 to Register the system. If you were under the impression you could use RHEL without registering, and paying, you are mistaken.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.