8

Something strange started happening to my terminal. Whenever I type some wrong command it tries to run that command in the background.

hegeek@colinux: ~# l   
[9]+  Stopped   l  
thegeek@colinux: ~# fdsl  

[10]+  Stopped                 fdsl  

What could be the issue?


EDIT:

After restarting the system the issue is solved. But I am still curious what caused this issue. I think it has to do something with command_not_found_handle shell function. While trying to find the command, it was doing something weird.

5
  • 1
    What output do you get from the alias command? Sep 3, 2010 at 22:09
  • just one "alias ls='ls --color=auto'". Its an new colinux installation.
    – Hemant
    Sep 3, 2010 at 22:13
  • 1
    Does saying /bin/sh -l fix it? If not, what about switching to another shell, like tcsh -l? Sep 3, 2010 at 22:17
  • 2
    this is a weird problem +1 because I've no clue. Sep 4, 2010 at 0:39
  • @Warren Young: After restarting ubuntu this problem solved. But I dont know what caused it.
    – Hemant
    Sep 4, 2010 at 4:31

1 Answer 1

6

That sounds like the command-not-found hook was acting up for some reason. I've had problems with it before, but never could figure out how to fix it :-/.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .