1

The version of glibc in the repository is 2.13 so I couldn't use apt-get to install it. I downloaded the source code of glibc-2.14, but when I run ./configure command I get this error:

checking for -z nodlopen option... yes
checking for -z initfirst option... yes
checking for -z relro option... no
configure: error: linker with -z relro support required

MySQL workbench relies on glibc-2.14. How can I get workbench installed?

  • You could do a local install of libc and link MySQL workbench against it, while leaving the system one alone (if possible). Replacing the system one with a locally compiled 2.14 may lead to bad things, and is not recommended. However, if MySQL Workbench is proprietary and expects the library location to be in a specific place, then you will have to upgrade to a newer version of Debian. I assume you are on wheezy? – Faheem Mitha Sep 16 '14 at 10:56
2

"testing" in Debian currently has libc6 2.19, does that workbench need exactly 2.14 or (more usually) at least 2.14... see packages.debian.org. I recommend updating your system to testing completely or to use pinning to selectively update packages.

Trying to compile glibc yourself is not something undertaken lightly, fighting the dependency hell while upgrading selectively to testing is a lot easier :-)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.