2

Some time in 3.15, someone moved the rts5139 driver out of staging (I cannot find a changelog of this) and it got renamed to rtsx_usb. This, unfortunately, broke support for at least the RTS5139 card reader. I have found about zero other people on the internet having this problem (buried under all of the SVC repos that got indexed?), and was curious as to whether anyone here was having a similar problem and had fixed it.

Kernel versions tested to be experiencing the problem:

  • 3.17.0-rc4

lsmod | grep rts:

rtsx_pci               37855  0 
rtsx_usb               17487  0 
mfd_core               12601  3 lpc_ich,rtsx_pci,rtsx_usb
usbcore               187093  9 btusb,snd_usb_audio,uvcvideo,rtsx_usb,snd_usbmidi_lib,ehci_hcd,ehci_pci,usbhid,xhci_hcd

lsusb | grep -i rts:

Bus 001 Device 009: ID 0bda:0139 Realtek Semiconductor Corp. RTS5139 Card Reader Controller

Removing/reinserting the rtsx_usb module does nothing. Logs are silent when the reader is interacted with. Strange.

4
  • I have the same problem with kernel 3.16.6 and the RTS5129 card reader.
    – TobiMarg
    Commented Dec 20, 2014 at 16:05
  • On OpenSUSE this problem is fixed with kernel 3.16.7
    – TobiMarg
    Commented Dec 21, 2014 at 16:08
  • Same here on Linux Mint 17.2 under VirtualBox. It worked under Ubuntu 12.04...
    – carveone
    Commented Oct 3, 2015 at 13:06
  • As of 4.0 this appears to be fixed.
    – Roman
    Commented Nov 23, 2015 at 19:53

2 Answers 2

0

Just an idea: partitions on memory cards are now found under names such as /dev/mmcblk0p1. Maybe you have been waiting for /dev/sdb1 to appear? Make sure rtsx_usb is loaded and try to mount /dev/mmcblk0p1 (or a similar name).

If that's not a solution for you, you might want to modprobe rtsx_usb and post the related output of dmesg? In my case, it's

usbcore: registered new interface driver rtsx_usb
mmc0: new SDHC card at address e624
mmcblk0: mmc0:e624 SD04G 3.69 GiB 
mmcblk0: p1

Of course, you would make sure that the rtsx_usb_-related modules aren't already loaded when you modprobe.

Just as an additional info:

lsmod | grep rts

rtsx_usb_ms            16899  0 
memstick               13696  1 rtsx_usb_ms
rtsx_usb_sdmmc         25280  0 
rtsx_usb               17541  2 rtsx_usb_sdmmc,rtsx_usb_ms
mmc_core              102374  2 mmc_block,rtsx_usb_sdmmc
mfd_core               12601  2 lpc_ich,rtsx_usb
usbcore               195340  7 usblp,uvcvideo,rtsx_usb,ehci_hcd,ehci_pci,usbhid,xhci_hcd
1
  • Nope. Dead silent.
    – Roman
    Commented Feb 14, 2015 at 3:33
0

As is pointed out in an answer to RTS5129 Card Reader with Ubuntu 15.10, asymingt wrote a temporary fix this.

Direct link to the github repo: https://github.com/asymingt/rts5139

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .