0

I have a problem with my new installation of ArchLinux with an encrypted partition. I guess I have done the same steps as before and it works on my other machine. The error message I get is:

ERROR: device 'UUID=[....]' not found. SKipping fsck.
ERROR: Unable to find root device 'UUID=[...]'.
You are being drpped to recovery shell 

I have not typed in the UUID, it is the same in both lines.

To fix this I have searched the internet. The first thing I have done was to change the HOOKS line in /etc/mkinitcpio.conf to:

HOOKS="base udev block autodetect modconf keyboard keymap encrypt filesystems fsck"

And the second thing I have done is to arch-chroot into it, install linux with pacman and doing:

grub-mkconfig -o /boot/grub/grub.cfg

I have also checked the /etc/fstab file and this looks also correct and the grub UUID in the grub.cfg file looks also correct I have checked this with blkid. It is the UUID of /dev/mapper/vgarch-lvroot. The same counts for the machine on which it works.

And the third thing I have done was to reinstall grub and redoing the steps but none of this has worked.

Resources: first, second

I am looking forward to hear from you.

  • You need the encrypt hook in your mkinitcpio.conf as per the Arch wiki article... – jasonwryan Sep 14 '14 at 18:01
  • Er, sry I had typed in here the wrong HOOKS line here, I have edited my post now. On my pc I have included encrypt – Greeneco Sep 14 '14 at 18:12
  • So you are working with LVM as well? Post the relevant parts of your grub config and the output of lsblk. – jasonwryan Sep 14 '14 at 18:14
0

I have solved my question, I have simply forget to add lvm2 in the HOOKS line of /etc/mkinitcpio.conf. Now it looks like:

HOOKS = "base udev autodetect modconf block keyboard keymap encrypt lvm2 filesystems fsck shutdown"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.