I have successfully installed ArchLinux.

While I check /etc/fstab entries I do not see any mounts, even the root partition is omitted. However when I execute mount, it shows the mount-points of each on my system.

My question is how my file-system gets mounted. Would it have something to do with systemd?

Here is the output of mount

proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)            
sys on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)   
dev on /dev type devtmpfs (rw,nosuid,relatime,size=924480k,nr_inodes=231120,mode=755)
run on /run type tmpfs (rw,nosuid,nodev,relatime,mode=755)  
/dev/mapper/vg_archlinux-lv_root on / type ext4 (rw,relatime,data=ordered)   
securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)
  • Did you check this? Could you add the output of /etc/fstab and mount as well? Could you explain the assumption that it has something to do with systemd? – 030 Sep 14 '14 at 10:07
  • I assume that udev got something to do with it. – Ghanima Sep 14 '14 at 10:49
  • @utrecht: for your reference i added the output of mount. However, as i said my /etc/fstab is an empty file. – krs4keshara Sep 14 '14 at 11:04
  • @krs4keshara Could you indicate which version of ArchLinux you are using? According to this documentation the /etc/fstab should contain content. Did you run lsblk -f? – 030 Sep 14 '14 at 11:13
  • @utrecht: yeah, i checked that doc. It gives an output of what it supposed to when i execute lsblk -f according to the mentioned document. But what i am still trying to understand how on earth my file-system gets mounted with empty /etc/fstab. – krs4keshara Sep 14 '14 at 11:25

This problem is solved! - many thanks to utrecht.

what i learn during this is that any system do mounts /root partition using the bootloader in the first place. After that they are remounted by systemd if only they exist in /etc/fstab.

Due to some reason, my /etc/fstab did not generate as it should withing the installation. But the reason it worked was that bootloader mount required mount-points when the system boots.

| improve this answer | |
  • /boot/ is not remounted (as your mount output shows), nor does it need to be... – jasonwryan Sep 14 '14 at 20:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.