1

I am running Debian GNU/Linux Jessie (testing) on my laptop. I enabled the systemd laptop-mode service:

$ sudo laptop_mode
Laptop mode 
enabled, active [unchanged]

and in my /etc/laptop-mode/conf.d/cpufreq.conf I have (trimmed everything else, using defaults)

CONTROL_CPU_FREQUENCY=1
BATT_CPU_GOVERNOR=powersave
LM_AC_CPU_GOVERNOR=powersave
NOLM_AC_CPU_GOVERNOR=performance

which are modes supported by all my CPUs:

cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_available_governors
performance powersave
performance powersave
performance powersave
performance powersave

However, if I reboot with AC (or plug in the mains) and look in

cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor 
powersave
powersave
powersave
powersave

all the CPUs are using powersave.

So why is my config being ignored? How can I fix this?

Relevant info:

  • I do not have pm-utils or acpid installed (because they are known to conflict with systemd and laptop-mode in various ways)
  • this was on a fresh install and there are no legacy CPU config options left over in any other laptop-mode config file.
4

AHA! It turns out that my CPUs support pstate and this seems to show up as powersave mode but in actual fact it is a custom governor.

With this, it means that laptop-mode ignores all the cpufreq settings and instead looks in /etc/laptop-mode/conf.d/intel_pstate.conf. In here, custom scaling rules can be applied (and I confirm that they are picked up!)

Indeed, there are a few other Intel specific modules here and I'm off to read about them all.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.