5

I have just installed Vimperator 3.8.2 on Firefox 32 (running Fedora 20). The status bar at the bottom of the window does not display any information in Normal mode , even though when I do

:set status?

I get

status=input,location,bookmark,history,tabcount,position,

Nor do I get the little highlighted Error indicator, or mode indicators when I enter Insert or Caret. Everything else seems to work just fine. I haven't modified any of the default values.

What might be causing this?

  • Have you tried posing this question on Freenode@#vimperator? – eyoung100 Sep 11 '14 at 17:30
13

There's a possibility of forgeting enabling Liberator Statusline Toolbar. Right-click on places like Menu bar, Address bar, Toolbar, etc. A menu shows up in which you will find a line named "Liberator Statusline Toolbar". Click on it to enable. The Vimperator status bar magically appears again.

  • This worked for me. – Max Jan 24 '15 at 7:44
  • Worked for me too. Even more than 1 year later. – Thales MG Apr 5 '16 at 0:14
1

The culprit turned out to be one of the extensions I installed earlier, most likely an earlier version of Hide Tabbar or Hide Navigation Bar. These modify localstore.rdf, located in Firefox's profile directory (~/.mozilla/firefox/**.default in my case), which tells Firefox which bars and windows to display and which to hide. These extensions seem to change localstore.rdf permanently, i.e., uninstalling them doesn't restore the file to its original state. One fix is to remove localstore.rdf, Firefox will create a new one when it restarts. This will reset all the toolbar settings, though, so you will need to redo all the changes you may have done before.

The latest versions of Hide Navigation (1.41) and Hide Tabbar (2.1.0) do not seem to have this problem.

Hat tip to E Carter Young for suggesting to post this on freenode#vimperator.

1

For me the problem was fixed by deleting the whole profile directory like this:

rm -rf ~/.mozilla/firefox/<bunch of characters>.default

Removing localstore.rdf as suggested by @user4025526 and E Carter Young did not work in my case. (Iceweasel 31.1.0 on Debian Jessie)

Removing and reinstalling Vimperator also failed.

In my case the problem was probably not caused by other extensions interfering. The only other extension I had installed was AdBlock Plus.

Removing the whole profile is probably overkill. And I had to install all extensions from scratch afterward. But it did fix the status bar issue.

Hopefully someone with better knowledge of FF internals will chime in.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.