0

I'm a starting security/Linux student and I'm having headache-problems getting my wireless to work on Kali Linux.

Recently I've bought a new laptop, to be specific the: Lenovo IdeaPad Z50-70-01418NL It comes with the wireless card: Realtek RTL8723BE Wireless LAN 802.11n PCI-E

Lenovo only supports Windows, so I went searching for possibilities to get my wireless to work (After all, I've bought a laptop for a reason)

I Really have googled everything, and because of that I'm losing track of what is relevant and what is not, what is the right way and what isn't.

The https://github.com/lwfinger/rtl8723be shows the following line: "Code for new variety of the 8723 PCI cards - temp until code added to kernel"

So I assume that I must compile the driver and ultimately install the driver into my system as following:

  1. command 'make' to compile the driver
  2. get the driver in the right place
  3. Profit!

I try to 'make' the "rtl8723be" code but whatever I try it keeps giving me build errors. Since I have been trying almost anything in the hope it will work there is a long history of errors, but mostly the errors point at the line of:

$(MAKE) -C $(KSRC) M=$(PWD) modules

Ultimately I want to get my rtl8723be driver to work. If I use

ndiswrapper -i <.inf-file>' 

It seems that ndiswrapper installs the .inf file and ndiswrapper -l is showing the driver.

But I've red that you must use

modprobe ndiswrapper

This results in:

FATAL: Module ndiswrapper not found

~~~~~~~~~~ EDIT ~~~~~~~~~~~~

So I have reinstalled the OS. (First tried to install kernel 3.15 but still no wifi adapter) Installed the needed kernel-headers. And I downloaded the new "rtl8723be" from https://github.com/lwfinger/rtlwifi_new

(The new version fixes the bug in trx.c = Fix version number for _ieee80211_is_robust_mgmt_frame)

When I try to use 'make' this results in the following:

root@Kratos:~/rtlwifi_new/rtl8723be# make
make -C /lib/modules/3.14-kali1-amd64/build M=/root/rtlwifi_new/rtl8723be modules
make[1]: Entering directory `/usr/src/linux-headers-3.14-kali1-amd64'
  CC [M]  /root/rtlwifi_new/rtl8723be/dm.o
  CC [M]  /root/rtlwifi_new/rtl8723be/fw.o
  CC [M]  /root/rtlwifi_new/rtl8723be/hw.o
  CC [M]  /root/rtlwifi_new/rtl8723be/led.o
  CC [M]  /root/rtlwifi_new/rtl8723be/phy.o
  CC [M]  /root/rtlwifi_new/rtl8723be/pwrseq.o
  CC [M]  /root/rtlwifi_new/rtl8723be/pwrseqcmd.o
  CC [M]  /root/rtlwifi_new/rtl8723be/rf.o
  CC [M]  /root/rtlwifi_new/rtl8723be/sw.o
  CC [M]  /root/rtlwifi_new/rtl8723be/table.o
  CC [M]  /root/rtlwifi_new/rtl8723be/trx.o
  LD [M]  /root/rtlwifi_new/rtl8723be/rtl8723be.o
  Building modules, stage 2.
  MODPOST 1 modules
WARNING: "rtl_btc_get_ops_pointer" [/root/rtlwifi_new/rtl8723be/rtl8723be.ko] undefined!
  CC      /root/rtlwifi_new/rtl8723be/rtl8723be.mod.o
  LD [M]  /root/rtlwifi_new/rtl8723be/rtl8723be.ko
make[1]: Leaving directory `/usr/src/linux-headers-3.14-kali1-amd64'

So what does this error mean? WARNING: "rtl_btc_get_ops_pointer" [/root/rtlwifi_new/rtl8723be

I Have the feeling I'm almost there.

I Even tried to copy both the driver and firmware to the following folders:

/lib/modules/3.14-kali1-amd64/kernel/drivers/net/wireless/rtlwifi/rtl8723be/rtl8723be.ko

/lib/firmware/rtlwifi/rtl8723befw.bin

1
  • This is a warning, not an error, it should be safe to ignore. Does modprobe work after copying the files?
    – fkraiem
    Sep 11, 2014 at 21:43

1 Answer 1

1

For the rtl8723be drivers, just update the kernel.

Click here and follow all steps:

https://forums.kali.org/showthread.php?22638-rtl8723be-wireless-driver-installation&p=37193&viewfull=1#post37193

2
  • Nice! I've already installed 3.15 but that didn't help. After installing 3.15.1 it finally recognised the wireless card but it's still too unstable to work with. When I have time I'll try to update to kernel 3.16 and report back. For now: a big thanks!
    – Nielsv
    Sep 19, 2014 at 14:12
  • It is now finally running stable with kernel 3.16 Thank you very much, this took a long time. I'm still a bit frustrated why I couldn't get ndiswrapper && the compiling if the driver too work.
    – Nielsv
    Sep 23, 2014 at 10:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .