1

An SSH server using RSA keys for authentication is running on Ubuntu 14.04.

My original account can connect to the server using SSH (PuTTY).

However, the following issue occurs:

Disconnected: No Supported authentication methods available (server sent: publickey)

if additional users are trying to authenticate, while these have been added to the /etc/ssh/sshd_config file as authorized users.

Pageant runs on my machine so I am not sure what is going on. The private key is there. What am I missing?

  • If you modify /etc/ssh/sshd_config you need to restart (or send a HUP signal to) the ssh daemon for the changes to take effect. Also, it's not normally necessary to explicitly allow existing users to log on via ssh. Are you doing this for a specific purpose? Do you really have users who should not be able to log on via ssh? – András Korn Sep 10 '14 at 12:10
  • If someone wants to write an answer for this, here are the things to think about explaining: a config that isn't refreshed, the server not having the pub-key, or a client that doesn't support key auth only uname/pwd auth. – RobotHumans Sep 10 '14 at 12:13
2

setting ssh permission can be tricky.

  • ~/.ssh is drwx------ ?
  • authorized_keys is -rw-r--r-- ?
  • $HOME (A's or B's) shouldn't be world writable.
0

Thanks all - I managed to work it out by restarting the service after I made the changes to the sshd_config file. I also created subfolders in /etc/ssh/ for each user and copied the "authorized_keys" file from my folder to the new users folders. (not sure if that was actually needed or not but did it anyway)

  • You're sharing ssh private keys? This is not a good idea. – Patrick Sep 10 '14 at 12:48
  • No - I am the only user of the system. These accounts setup are for testing purposes only. – user53029 Sep 10 '14 at 13:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.