0

I want to add phpmyadmin to Kali Linux. But i am getting the following error. First i ran apt-get update which worked successfully than the following. Here is the output of apt-get update

root@kali:~# sudo apt-get update
Hit http://http.kali.org kali InRelease                                        
Hit http://http.kali.org kali/main Sources                                     
Hit http://http.kali.org kali/non-free Sources                                 
Hit http://http.kali.org kali/contrib Sources                                  
Hit http://http.kali.org kali/main i386 Packages                               
Hit http://http.kali.org kali/non-free i386 Packages                           
Hit http://http.kali.org kali/contrib i386 Packages                            
Ign http://dl.google.com stable InRelease                                      
Hit http://dl.google.com stable Release.gpg                          
Hit http://dl.google.com stable Release        
Hit http://dl.google.com stable/main i386 Packages                    
Hit http://security.kali.org kali/updates InRelease                  
Ign http://dl.google.com stable/main Translation-en_IN                  
Ign http://dl.google.com stable/main Translation-en
Hit http://security.kali.org kali/updates/main i386 Packages
Hit http://security.kali.org kali/updates/contrib i386 Packages
Hit http://security.kali.org kali/updates/non-free i386 Packages
Ign http://http.kali.org kali/contrib Translation-en_IN
Ign http://http.kali.org kali/contrib Translation-en
Ign http://http.kali.org kali/main Translation-en_IN
Ign http://http.kali.org kali/main Translation-en
Ign http://http.kali.org kali/non-free Translation-en_IN
Ign http://http.kali.org kali/non-free Translation-en
Ign http://security.kali.org kali/updates/contrib Translation-en_IN
Ign http://security.kali.org kali/updates/contrib Translation-en
Ign http://security.kali.org kali/updates/main Translation-en_IN
Ign http://security.kali.org kali/updates/main Translation-en
Ign http://security.kali.org kali/updates/non-free Translation-en_IN
Ign http://security.kali.org kali/updates/non-free Translation-en
Reading package lists... Done
root@kali:~# 

After this i tried the following which is showing error ! !

root@kali:~# sudo apt-get install phpmyadmin
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
dbconfig-common libapache2-mod-php5 libmcrypt4 php5-cli php5-common php5-gd php5-mcrypt php5-mysql
Suggested packages:
php-pear libmcrypt-dev mcrypt
The following NEW packages will be installed:
dbconfig-common libmcrypt4 php5-gd php5-mcrypt phpmyadmin
The following packages will be upgraded:
libapache2-mod-php5 php5-cli php5-common php5-mysql
4 upgraded, 5 newly installed, 0 to remove and 635 not upgraded.
Need to get 5,503 kB/12.0 MB of archives.
After this operation, 17.2 MB of additional disk space will be used.
Do you want to continue [Y/n]? y
Err http://security.kali.org/kali-security/ kali/updates/main phpmyadmin all 4:3.4.11.1-2+deb7u1
Connection failed
Failed to fetch http://security.kali.org/kali-security/pool/main/p/phpmyadmin/phpmyadmin_3.4.11.1-2+deb7u1_all.deb  Connection failed
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
  • Please run and post the output of apt-get update – Jan Sep 10 '14 at 8:52
  • Better idea: don't. Kali Linux is a specialized pentesting distro. It is not meant to be used as a desktop OS, much less a server OS. It tracks the testing Debian archive, which is where Debian puts everything that's not production ready yet. Install a real distribution to run your server on. – Shadur Nov 12 '17 at 11:42
1

The security.kali.org website may have had a hickup. Try to ping it:

[root@fly2 ~]# ping -c 3 security.kali.org
PING security.kali.org (173.246.39.190) 56(84) bytes of data.
64 bytes from http.kali.org (173.246.39.190): icmp_seq=1 ttl=57 time=126 ms
64 bytes from http.kali.org (173.246.39.190): icmp_seq=2 ttl=57 time=127 ms
64 bytes from http.kali.org (173.246.39.190): icmp_seq=3 ttl=57 time=126 ms

This indicates the website works. You can also try to browse to http://security.kali.org/kali-security/ to see if you get a directory listing. If that works, try again.

  • I used the ping command as you mentioned.But i am only seeing the first line. root@kali:~# ping -c 3 security.kali.org PING security.kali.org (173.246.39.190) 56(84) bytes of data. --- security.kali.org ping statistics --- 3 packets transmitted, 0 received, 100% packet loss, time 2017ms When browsing to the link mentioned i am able to see the directory tree. – Sanchit Jain Sep 10 '14 at 9:56
  • Your DNS works, looking at the "security.kali.org (173.246.39.190)", so I assume there is no general network issue. Perhaps pinging is blocked by a firewall. Try this: telnet security.kali.org 80 – Onnonymous Sep 10 '14 at 11:20
  • yes it is saying connected to security.kali.org – Sanchit Jain Sep 10 '14 at 11:35
  • That's great! Could you try again to do the sudo apt-get install phpmyadmin? – Onnonymous Sep 10 '14 at 11:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.