0

I have one PC with two disk drives. The first one has Win 7 Pro on it (sda1). The second drive has Linux CentOS 7 (sda). I want to be able to access everything in sda1 while I am running CentOS from sda. I tried mounting it, but I got the following error:

what I tried: mount /dev/sda1 /media/windrive

The error I got: mount: unknown filesystem type 'ntfs'

3
  • 1
    first, post the output of lsblk -f to make sure you got the correct drive. Your statements on sda and sda1 make me doubt that you got the correct drive. If there is something installed on /dev/sda (unpartioned) then there is no /dev/sda1!
    – Sebastian
    Sep 9 '14 at 21:51
  • /dev/sda would be an unpartitioned raw device, and /dev/sda1 the first partition on the same physical drive, so what you're describing can't possibly be what you have.
    – tink
    Sep 9 '14 at 21:54
  • lsblk -f shows sda name=(sda1,sda2) fstype=(ntfs,ntfs) label=(System,OSDisk), nothing under mountpoint. It also shows sdb name=(sdb1,sdb2) with fstype=(xfs, LVM2_member) with mountpoint /boot, [SWAP], /, and /home. Clearly sda1, sda2 refer to the Windows, and sdb1, sdb2 refer to Linux.
    – user82350
    Sep 9 '14 at 22:24
1

You may need to install the following required packages which Centos by default does not support ntfs (Make sure you have the rpmforge repo installed)

Install the following packages.

             yum install fuse fuse-ntfs-3g

If the rpmforge repo is disabled by default,

             yum --enablerepo=rpmforge install fuse fuse-ntfs-3g

create a mount point

         mkdir /mnt/nftsdrive

Next, edit /etc/fstab as follows.

To mount read-only:

         /dev/sde1 /mnt/ntfsdrive ntfs-3g ro,umask=0222,defaults 0 0

To mount read-write:

        /dev/sde1 /mnt/ntfsdrive ntfs-3g rw,umask=0000,defaults 0 0

You can now mount it by running:

        mount /mnt/nftsdrive
6
  • I got the following error: unknown filesystem type 'ntfs-3g'
    – user82350
    Sep 9 '14 at 22:25
  • try to see if ntfs module is loaded by modprobe ntfs command and also check if rpm -qa ntfs* was installed.
    – Raza
    Sep 9 '14 at 22:29
  • modprobe ntfs says FATAL: Module ntfs not found. rpm -qa ntfs* takes a while, but returns to the prompt without errors.
    – user82350
    Sep 9 '14 at 22:48
  • how about modprobe fuse, please make sure both patches install properly.
    – Raza
    Sep 9 '14 at 22:56
  • check this link wiki.centos.org/TipsAndTricks/NTFS. if you are running CentOS 5.3 or older then you would need to install kmod-fuse.
    – Raza
    Sep 9 '14 at 23:02
0

Try this out. Create a mount point:

mkdir /mnt/ntfs 

Then try to mount:

mount -t ntfs /dev/sda1 /mnt/ntfs 

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.