2

I've installed Kali Linux over Windows 8; Kali is installed in a separate ext4 partition (sda2) and Windows in sda1. Now GRUB is not finding Windows 8 on startup!

I can see Windows 8 with the os-prober command.

What shall I do?

0

Assuming you haven't actually installed over Windows and that 0s-prober can indeed see a Windows installation, you just need to reinstall GRUB so it will detect Windows:

$ sudo update-grub

I am not familiar with Kali so if the above command is not available, use this instead:

$ sudo grub-mkconfig -o /boot/grub/grub.cfg

This will detect your installed operating systems and update GRUB to provide access to them.

|improve this answer|||||
  • @albertpaulp, you're very welcome. If this answer solves your issue please take a minute and click the check mark under the vote count to the left, this will signify to everyone that your issue's been resolved and is the way that thanks are expressed in the site. – terdon Sep 9 '14 at 12:54
  • I thought I already done that, it's done now. Thank you. – Albert Paul Sep 10 '14 at 17:25
0

Another way is to select in the bios the option to boot from uefi (windows boot manager or something like that) .

that way, when you select the legacy support you use grub to boot the linux partition, and when you select the uefi boot you go directly to windows.

|improve this answer|||||

Not the answer you're looking for? Browse other questions tagged or ask your own question.