0

I had a perfectly working wi-fi connection on my Mint-KDE PC. Recently, I brought a Synology NAS and after some research figured that I need to set my eth0 to static IP for it to connect to NAS via ethernet cable. So, I added this line to my /etc/network/interfaces file:

auto eth0
iface eth0 inet static
address 192.168.1.99
netmask 255.255.255.0
gateway 192.168.1.100

Now, after I restarted my PC, my ethernet connected to Synology fine but I had a new problem, my internet connection is gone. It says that the connection 'my_wifi_name' is connected but I have no internet, no response even when I do ping google.com in the terminal. (ping: unknown host google.com)

This is my ifconfig response BEFORE changing my /etc/network/interfaces file: (With this setting the LAN cannot connect to NAS, it gives me Connection 'Wired Connection 1' deactivated.)

$ ifconfig
eth0      Link encap:Ethernet  HWaddr c8:60:00:de:b7:da  
          inet6 addr: fe80::ca60:ff:fede:b7da/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:6 errors:0 dropped:0 overruns:0 frame:0
          TX packets:63 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:3540 (3.5 KB)  TX bytes:12967 (12.9 KB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:651 errors:0 dropped:0 overruns:0 frame:0
          TX packets:651 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:85658 (85.6 KB)  TX bytes:85658 (85.6 KB)

vmnet1    Link encap:Ethernet  HWaddr 00:50:56:c0:00:01  
          inet addr:172.16.82.1  Bcast:172.16.82.255  Mask:255.255.255.0
          inet6 addr: fe80::250:56ff:fec0:1/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:104 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

vmnet8    Link encap:Ethernet  HWaddr 00:50:56:c0:00:08  
          inet addr:192.168.156.1  Bcast:192.168.156.255  Mask:255.255.255.0
          inet6 addr: fe80::250:56ff:fec0:8/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:105 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wlan0     Link encap:Ethernet  HWaddr 64:70:02:f0:b9:7f  
          inet addr:192.168.1.4  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::6670:2ff:fef0:b97f/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:627 errors:0 dropped:0 overruns:0 frame:0
          TX packets:626 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:395824 (395.8 KB)  TX bytes:110123 (110.1 KB)

This is my ifconfig response AFTER changing my /etc/network/interfaces file: (With this setting both the wi-fi and LAN connects to NAS, but internet is unavailable despite the successful wi-fi connection status.)

$ ifconfig
eth0      Link encap:Ethernet  HWaddr c8:60:00:de:b7:da  
          inet addr:192.168.1.99  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::ca60:ff:fede:b7da/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:6 errors:0 dropped:0 overruns:0 frame:0
          TX packets:140 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:3540 (3.5 KB)  TX bytes:17523 (17.5 KB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:894 errors:0 dropped:0 overruns:0 frame:0
          TX packets:894 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:88248 (88.2 KB)  TX bytes:88248 (88.2 KB)

vmnet1    Link encap:Ethernet  HWaddr 00:50:56:c0:00:01  
          inet addr:172.16.82.1  Bcast:172.16.82.255  Mask:255.255.255.0
          inet6 addr: fe80::250:56ff:fec0:1/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:61 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

vmnet8    Link encap:Ethernet  HWaddr 00:50:56:c0:00:08  
          inet addr:192.168.156.1  Bcast:192.168.156.255  Mask:255.255.255.0
          inet6 addr: fe80::250:56ff:fec0:8/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:61 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wlan0     Link encap:Ethernet  HWaddr 64:70:02:f0:b9:7f  
          inet addr:192.168.1.4  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::6670:2ff:fef0:b97f/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:60 errors:0 dropped:0 overruns:0 frame:0
          TX packets:59 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:3465 (3.4 KB)  TX bytes:11879 (11.8 KB)

What am I doing wrong here? I have no clue, no help from googling either. Thanks.

EDIT: This is my ip route command output:

$ ip route
default via 192.168.1.1 dev wlan0  proto static 
172.16.82.0/24 dev vmnet1  proto kernel  scope link  src 172.16.82.1 
192.168.1.0/24 dev wlan0  proto kernel  scope link  src 192.168.1.4  metric 9 
192.168.156.0/24 dev vmnet8  proto kernel  scope link  src 192.168.156.1 

Also, I chose the address and gateway in my /etc/network/interfaces randomly, I had it as follow at first but changed it to another value as shown in original question in hopes that it might make it work. I clearly have no idea what those values signify, I think those are the static ip that'll be associated with eth0 and my Synology will read it and lock into that static address.

`/etc/network/interfaces' file used at first attempt:

auto eth0
iface eth0 inet static
address 192.168.1.2
netmask 255.255.255.0
gateway 192.168.1.1
5
  • 1
    What is the device at 192.168.1.100? Is that your router/modem? Sep 9, 2014 at 5:26
  • You could also add the output of ip route and the content of /etc/resolv.conf to your question. Sep 9, 2014 at 5:34
  • @garethTheRed I have edited my questions with additional information as you requested. Thanks for the interest. Sep 9, 2014 at 6:36
  • 1
    I notice that you used the same subnet (192.168.1.x) for both interfaces. I'm no networking expert, but I can imagine that this is a problem, since (if I understand your setup correctly) they are not really the same network. So maybe it helps if you change your eth0 address to 192.168.2.99 instead?
    – celtschk
    Sep 9, 2014 at 8:49
  • That was it, thanks for the help. I also had to change the gateway to 192.168.2.*. Sep 10, 2014 at 2:41

0

You must log in to answer this question.

Browse other questions tagged .