3

I am loading fedora20 directly from a SATA drive connected via USB. The problem is that I will be working and all of a sudden the drive seems to have been put to sleep and nothing will work except what is already in RAM.

If I restart the computer, the drive is still sleeping and will load windows instead of fedora even though the fedora drive is above the windows one. This is because the drive is connected via an alternate power supply and I suppose it thinks it is still sleeping. The only way to fix this is to disconnect the power from the fedora SATA drive and reboot.

I found this article for Ubuntu https://askubuntu.com/questions/80638/how-to-disable-auto-power-off-of-usb-devices-like-usb-mouse

How can I disable autosleep for USB on a fedora20 OS?

  • Actually I read it more carefully and there is a product called tlp. askubuntu.com/questions/285434/… – jax Sep 8 '14 at 5:31
  • In the end, unfortunately, this still didn't work. The drive continued to sleep intermittently. I had to reinstall while plugged into a SATA port and forget the whole USB idea. – jax Sep 26 '14 at 14:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.