2

Update: The solution down there works, but Hipchat messed with my system so I would suggest anyone with the same problem to try the solution, and then check if he encounters any of these issues.

[I am trying to install Bitmask on my system(Fedora 20) to get the riseup VPN running.

Running ./bitmask after unpacking the tarball gives the following output:

Bitmask-linux64-0.6.1-4]# ./bitmask
No updates found
/home/GlaDOS/Downloads/Bitmask-linux64-0.6.1-4/./apps/:/home/GlaDOS/Downloads/Bitmask-linux64-0.6.1-4/./lib/
Could not find platform independent libraries <prefix>
Could not find platform dependent libraries <exec_prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
Traceback (most recent call last):
  File "apps/launcher.py", line 8, in <module>
    from leap.bitmask.app import start_app as bitmask_client
  File "/home/GlaDOS/Downloads/Bitmask-linux64-0.6.1-4/./apps/leap/bitmask/__init__.py", line 26, in <module>
    from leap.bitmask.util import first
  File "/home/GlaDOS/Downloads/Bitmask-linux64-0.6.1-4/./apps/leap/bitmask/util/__init__.py", line 25, in <module>
    from leap.common.config import get_path_prefix as common_get_path_prefix
  File "/home/GlaDOS/Downloads/Bitmask-linux64-0.6.1-4/./lib/leap/common/__init__.py", line 3, in <module>
    from leap.common import certs
  File "/home/GlaDOS/Downloads/Bitmask-linux64-0.6.1-4/./lib/leap/common/certs.py", line 26, in <module>
    from OpenSSL import crypto
  File "/home/GlaDOS/Downloads/Bitmask-linux64-0.6.1-4/./lib/OpenSSL/__init__.py", line 36, in <module>
    from OpenSSL import crypto
ImportError: libssl.so.1.0.0: cannot open shared object file: No such file or directory

The program does not start up because of this(probably), so does anyone have an idea for a solution?]

  • 2
    Is openssl installed? – Jan Sep 7 '14 at 21:56
  • How to solve the error to get the programm running. – Merlin Sep 7 '14 at 21:57
  • You probably need to install pyOpenSSL package. – Erdem May 26 '15 at 17:57
2

That version of the file libssl.so.1.0.0 doesn't appear to be available on a stock F20 system. Here's what I get when I search for it on my laptop:

$ repoquery -qf */libssl.so.1.0.0
hipchat-0:2.2.1163-1.x86_64
hipchat-0:2.2.1163-1.i386

It's only available from this 3rd party package, hipchat. So the application you're attempting to build appears to have been written/configured to use this particular version of that library.

I'd be tempted to ask this question on the project's main site, since it seems to be an issue with the source code.

  • yum cannot find a package called hipchat and there is none listed in the Fedora package database. Can you tell me where to get it from(I probably have to add a repository?)? – Merlin Sep 16 '14 at 20:20
  • @Merlin - Yes, hipchat is installed from a 3rd party repo. It's a proprietary app. My intent with this A wasn't to have you install hipchat, but rather to run that repoquery command on your system. I'd need more info about the app to assist further. That app was built against this library and it doesn't appear to be a standard library in F20. – slm Sep 16 '14 at 20:26
  • Well, I get no output when running repoquery. – Merlin Sep 16 '14 at 20:37
  • It seems to be that Bitmask as of now is rather supposed to be installed on Ubuntu, but still, the stand alone bundle should be install-able on other systems... bitmask.net/en/install/linux – Merlin Sep 16 '14 at 20:43
  • You could just install hipchat to get this library 8-) hipchat.com/download. – slm Sep 16 '14 at 21:03
0

You need to install openssl-libs first...

After that, libssl.so.1.0.0 should be in /usr/lib

  • There only seems to be an equivalent called openssl-devel for Fedora. I installed that one, but I still get the same error. – Merlin Sep 7 '14 at 22:13
  • I also tried what is suggested here linuxquestions.org/questions/fedora-35/… but it does not work and I am not sure how to go about "digging out libssl.so.0.9.8k from the Fedora 11 package". – Merlin Sep 7 '14 at 22:15
  • My mistake, in Fedora the package is called openssl. Corrected my answer. – Jan Sep 7 '14 at 22:21
  • Openssl is installed and at the latest version. – Merlin Sep 7 '14 at 22:24
  • I don't have a fedora machine at hand, try to install openssl-libs and ls -l /usr/libs/libssl.so* – Jan Sep 7 '14 at 22:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.