I installed a bunch of applications via SSH on a Debian Wheezy server. Now I want to give one extra developer rights to use one folder.

I added her to a new group "myappdevs" and gave the group right to read and write the directory. When I login as the new user and check the programs for:

ruby -v

I see an old version returned. And for

rails -v



I get the errors [program] : command not found. For Vim it did work, but I had to copy my own Vim profile to the home directory of the new user for it to work.

I am new to setting up permissions and access. How can I give the new user access to ruby, bundle and rails?

  • 1
    Sounds like you need to adjust $PATH.
    – phemmer
    Sep 7, 2014 at 16:57
  • Hi @Patrick. To what? Same as root? :) Okay I did that and the problem is solved... Sep 7, 2014 at 20:12

2 Answers 2


Instead of chmod 777 /path/to/kppp you could do,

setfacl -R -m user:username:rx /path/to/kppp

Instead if you need to provide access to a particular group, you could do,

setfacl -m g:somegroup:rwx /path/to/kppp

As Patrick said in the comments I just needed to adjust the $PATH variable of the new user.

What I did was logging in as root, copied the result from echo $PATH. Then I logged in as the new user and did:

PATH=$PATH:[copy paste the $PATH result of root)

All programs now work. Problem solved. /edit, problem not solved since it was not a permanent change.

I had to put PATH = "[copy paste the $PATH result of root]"; export PATH in the ~./profile file.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .