7

I am trying to figure out why I am getting this boot errors. I have looked all through the dmesg, boot.log, kern.log. I also have a few modprobe -b pci:<PCI ID> errors during boot on the screen but I cannot find them in the logs. It takes about 5 minutes to boot.

DMI: BIOSTAR Group A75MH/A75MH, BIOS 4.6.4 04/17/2012

ata3: limiting SATA link speed to 1.5 Gbps
ata3: softreset failed (device not ready)
ata3: softreset failed (device not ready)
ata3: link is slow to respond, please be patient (ready=0)
ata3: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
ata3.00: failed to IDENTIFY (INIT_DEV_PARAMS failed, err_mask=0x80)
ata3: softreset failed (device not ready)
ata3: softreset failed (device not ready)
ata3: link is slow to respond, please be patient (ready=0)
ata3: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
8
  • Does that machine normally have SATA II ( 3 Gbps ) or even SATA III ?
    – Anthon
    Commented Sep 7, 2014 at 5:15
  • Did you recently install/upgrade Debian, or did you run it without these problems until now? Also, if possible switch of AHCI in the BIOS for the SATA drivers
    – Anthon
    Commented Sep 7, 2014 at 5:22
  • It does have SATA 3 Gbps that is what I am using most. It is a new install of Debian Wheezy. I will look in the bios for the AHCI option. . Commented Sep 7, 2014 at 5:25
  • Ok so got into the bios and the options were Native IDE, Raid, ACHI, Disable. I switched it from IDE to ACHI and I got the same errors on boot. I also found this. novell.com/support/kb/doc.php?id=3744228 Commented Sep 7, 2014 at 5:40
  • That is not good, switching off could in some cases help get rid of the errors in the past (at the cost of some lost SATA commands, but not of performance).
    – Anthon
    Commented Sep 7, 2014 at 5:54

2 Answers 2

3

There seem to have been SATA incompatibilities around 2009 that caused the "ata3: softreset failed (device not ready)" problem, but nowadays I would rather suspect failing hardware to be the cause.

If you suspect a drive failure, and you use SMART control on your drives (normally a BIOS option), you can check the drive for errors in your BIOS, or once the system still comes up with:

smartctl -H /dev/sdX

(adapting X to the actual drive letter: a, b, ...)

A more complete status can be obtained with:

smartctl --attributes -H /dev/sdX
1
  • In the case of an old controller (particularly SB600/SB700 I think), this can be worked-around with CONFIG_SATA_PMP=n. Commented Oct 22, 2016 at 23:54
1

AWESOME got it fixed bad HD. In the bios I looked at the drive configuration and one of the drives was registering 0.0 Gb but the drive is 500Gb. So I just unplugged it and rebooted no errors. I rebooted several times to make sure. No More Errors. Thanks! The one kinda odd thing is that the error states ata3 and the drive was on SATA port 1?

Not the answer you're looking for? Browse other questions tagged .