5

I've installed, configured and ran transmission-daemon on my CentOS 6 machine using

service transmission-daemon start

This works nicely, and I can see the web interface on http://server.ip:9091 as I need to. The problem is, that several minutes later, it spontaneously stops. Never says anything, without warning or error message.

This happens even when I have no torrents active at all (as in, none on the list).

I have no idea what's wrong, and the error logs I thought of (which probably isn't much) show nothing.

How can I diagnose the causes for this? Has anyone else experienced a similar problem?

EDIT

After the suggestion Martin gave me, I got the log. It goes like this:
[03:07:02.182] Transmission 2.13 (11501) started (session.c:624)
[03:07:02.182] RPC Server Adding address to whitelist: 127.0.0.1 (rpc-server.c:789)
[03:07:02.182] RPC Server Serving RPC and Web requests on port 9091 (rpc-server.c:962)
[03:07:02.182] DHT Generating new id (tr-dht.c:384)
[03:07:02.182] Using settings from "/var/lib/transmission/.config/transmission-daemon" (daemon.c:483)
[03:07:02.182] Saved "/var/lib/transmission/.config/transmission-daemon/settings.json" (bencode.c:1683)
[03:07:10.182] Port Forwarding State changed from "Not forwarded" to "???" (port-forwarding.c:95)
[03:07:18.188] Searching for web interface file "/var/lib/transmission/.local/share/transmission/web/index.html" (platform.c:526)
[03:07:18.188] Searching for web interface file "/usr/share/transmission/web/index.html" (platform.c:526)
[03:07:24.189] DHT Attempting bootstrap from dht.transmissionbt.com (tr-dht.c:241)

It hangs on that last one until it dies. Now I've looked into this question, but my settings file is already owned by transmission, and even changing the permissions on the file to 775 didn't seem to have any effects.

Any ideas?

1
  • I honestly don't have much clue where to look. If I'm missing any information on this question, please tell me and I'll edit it right away. Sep 4, 2014 at 22:22

3 Answers 3

4

I investigated similar problems a while ago, but on a Debian system.

Here's how i enabled logging. Since you run CentOS, you would need to adjust this a bit

sudo nano /etc/default/transmission-daemon

add to OPTIONS:

-e /var/log/transmission-daemon.log

create & give rights of logfile to transmission:

sudo touch /var/log/transmission-daemon.log
sudo chown debian-transmission:debian-transmission /var/log/transmission-daemon.log
sudo service transmission-daemon restart

Hope that helps!

1

i had this issue, turns out transmission.log had grown to over 7GB.

when i deleted it, everything went back to working as expected. i've created a cron to delete it on a schedule. hopefully that will keep it in check.

0

I encountered an error with transmission-daemon stopping when the main disk is full. It's a simple thing to overlook.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .