A week ago I tried to install Steam, I downloaded the .deb package and installed it, and played a game with it. In the next day, Steam prompted me with this:

Steam needs to install these additional packages:
libgl1-mesa-dri:i386, libgl1-mesa-glx:i386, libc6:i386

And then I did it, I installed those packages. But it broke my system. The next time I rebooted my system, it went straight to tty, no GUI. I tried a bunch of things to fix it but the only way (for me, a new guy to Linux) was to reinstall the system.

Now I'm trying to install it again and I found on the internet that installing ia32-libs would fix Steam. When I was going to install it, apt-get said that it would need to remove elementary-desktop. This is bad.

Right now I don't know how to install Steam without breaking my system. What's the proper way to install it?

If it's relevant, I'm using integrated graphics with an Intel Core i3 processor, Linux 3.2.0-51, distro: elementary OS Luna 64bit.

  • Please give additional information on your system. Linux version, 64 or 32, etc...
    – Jan
    Sep 4, 2014 at 21:26
  • Added info to the question.
    – Lucas T.
    Sep 4, 2014 at 22:00

2 Answers 2


This fixed it for me:

sudo apt-get install libgtk2.0-0:i386 libidn11:i386 libglu1-mesa:i386
  • 2
    Could you explain how you found this (and perhaps why it fixed it, if you know)? Oct 10, 2015 at 13:20

First, install a package manager on your system. Eddy and Debi Package Manager work well for this. Next, download the linux 64bit steam file from steam website. Open file using package manager by right clicking on file and opening with Eddy. The package manager ensures you have all the necessary repositories to run steam on linux.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .